Display problems with InstaLooper plugin

Hi everybody,

I’m still pretty new to GP and so far everything worked perfectly well for me. The possibilities in GP are amazing! But now I am experiencing problems with the InstaLooper (x64) plugin in GP4.

Anytime I load the plugin, it seems to me that the Windows Zoom level is being deactivated. I am running GP on a Surface Book 3 with a resolution of 3,000 x 2,000 on a 13.5 inch display so Windows automatically uses a 200 % zoom level. Now anytime I load the InstaLooper plugin the GP window turns small (about 1/4 of the display) and so do any buttons and text etc. If I maximize the window again all the buttons and text stay small and can hardly be read.

Here are some screenshots (full screen) with my test rackspace to see what I mean. The first screenshot is what GP looks like normally:

This is what it looks like after loading InstaLooper:

And this is after maximizing GP again with InstaLooper loaded:

I tried saving the file, closing GP and reloading the file but it won’t change anything. Anytime the plugin is loaded I have the same issue.

I then tried loading the plugin in Ableton 10 and it worked fine, no problems here.

If anybody wants to give it a try, the plugin can be downloaded here: https://freevstplugins.net/instalooper/. I assume there are no issues if you do not use Windows Zoom functionality.

Does anybody have similar problems and maybe has an idea how to fix it?

I hope you get what I mean. English isn’t my first language and this technical stuff isn’t always easy to explain :wink: Thanks in advance for any help!


That’s a very strange behaviour. How old is that plugin version that you’re using? They seem to be at version 3 now.

Thanks for trying to help me :wink: To tell the truth I dont’t know how old the plugin is. Version 3 is 85 € here and since I only look for a standard looping tool and don’t need any additional features I’d prefer the free version.

But if I can’t find a solution I might as well just look for another free plugin. If anybody has a recommendation for me I’d be thankful as well :slight_smile:

if you want a really simple looper, there is GLoop:
I’ve been using it in GP for a long time without encountering any problems, although it says on the developer’s site:
“Anything here may be incomplete, buggy or just rubbish - you have been warned”. :no_mouth:
I control it with footswitches.
I think you can use multiple instances if you need to, but that’s to be verified.

1 Like

Nice! I think, i will give this one a try… of course i could use Cubase, but for a quick&dirty GP-session this seems to be exactly the right thing. And it’s free… cooll!

Thanks, that sounds interesting! I’ll check it out whenever I find the time (which unfortunately may take a while…)!