Disable "Reopen Windows" Dialogue

I’m setting up a machine the will be run headlessly, so I need to eliminate any dialogs that might halt start up. After an abnormal shutdown, GigPerformer is offering a reopening of windows, and I really need to make it not do that. I’m on GigPerformer 4. Is there I way to fix this?

Thank you,
-M.

Is this the option that you’re looking for: Prevent apps and windows from reopening - Apple Support

1 Like

I appreciate the response. No, this isn’t what I’m looking for. What I’m talking about is a dialogue that comes up on next boot if you force quit GP. I haven’t seen it again since I mentioned it though, so maybe it’s a non-issue. Shrug.

@mechanica could you please post a screenshot of the dialog displayed on your system? I can use my GP rig headless and it works flawlessly…

This is a Mac “feature”

See Method 2 in this article

There is a GP dialog box that mentions reopening windows (not MacOS) that can appear after a force quit.

I had never seen it before I began ‘breaking’ GP with some of my external API developments. I will be able to provide a screenshot later.

The OS would have to restart Gig Performer - it doesn’t do it by itself. We would have to be running a background daemon (for example) to be able to do such things.

This is the dialog I’m talking about. So curious if it’s the same one @mechanica was talking about.
You get it the next time you open Gig Performer after a crash/hang, but not in all instances, as I never previously got this message.

This is a system dialog. It’s not something we built in so you’d have to look at the OS settings to disable something like this. Generally though - force-quitting should only be reserved for situations when its really needed, not as a shortcut for a quick exit.

Ok, no problem.

@rank13

Does this solve that issue? Disable "Reopen Windows" Dialogue - #2 by npudar

Is there any other setting that I couldn’t find? :thinking:

I immediately supposed that this is a Mac thing, as there are no GP services/deamons running in background.

Nah, I already have those settings applied.
It’s not an issue for me, as I only get it after a crash (that’s of my own making). I was just assuming it was GP generated based on the use of the GP icon, but know better now.

So, for a change, no problem with Windows reopening something. :stuck_out_tongue_closed_eyes:

Yes! Thank you for posting that, that’s the one. I haven’t been able to recreate it to take a picture.

Very misleading with it styled like GP, I was also under the assumption it was a built-in.

Probably a non-issue. But really wouldn’t want that coming up while starting up headlessly.

What that made me think of was the midi controllers or software such as Bomes that can convert a midi message to a keystroke, to allow you to get past those unexpected windows.

Ah, good suggestion. I’ve used ControllerMate for this sort of thing for a long time. Excellent software, although unfortunately no longer being developed as far as I can tell. Big Sur compatibility is questionable.