Crashing on startup

Hey guys. I have a huge problem. Gig Performer is crashing on startup and I have gigs coming up soon. I’m freaking out. I’ve attached the crash report. I hope someone has an answer for me or my band leader is gonna be pissed.

Thanks to whoever saves my butt.

_ jon

Crash Report.pdf (129.9 KB)

It looks like Neutron3 is the problem.
I would startup a blank gig, then in the Plugin Manager disable Neutron3. Then you can load the gig file and try to work out the issue.

This is a very weird crash report — when I look at the entries that actually reference code inside Gig Performer, the sequence of calls simply doesn’t make any sense.
It is true that the crash is clearly happening in Neutron3 and so the suggestion from @edm11 should be followed, but I’d like to understand more about this

  1. Was this gig file working and then suddenly started crashing or did it crash the very first time you inserted Neutron3?
  2. If the former, how long has it been working and did something change on your machine that instigated this crash?
  3. There are references to the streaming audio file player, timelines and OSC, all mixed together in a way that makes absolutely no sense - are you doing anything with those three things?

OMG ur the friggin man!!! You just saved my butt. I owe you a beer. And you responded so quickly. This is the best forum. Someone always responds.

So how do I know what made the crash? for the next time that this happens. Looks like it’s the first plugin that shows up after “Thread 0 crashed…”

Thread 0 Crashed:: HotFudge Dispatch queue:
0 iZNeutron3 0x128ad857c 0x127302000 + 24995196
1 iZNeutron3 0x127b1108d 0x127302000 + 8450189
2 iZNeutron3 0x127b108d6 0x127302000 + 8448214
3 iZNeutron3 0x127d81519 0x127302000 + 11007257
4 iZNeutron3 0x127d9fe6c 0x127302000 + 11132524
5 iZNeutron3 0x127d8cfcf 0x127302000 + 11055055
6 iZNeutron3 0x127d9fd10 0x127302000 + 11132176
7 iZNeutron3 0x127d9c690 0x127302000 + 11118224
8 iZNeutron3 0x127d889ad 0x127302000 + 11037101
9 iZNeutron3 0x127d9817f 0x127302000 + 11100543

1 + 2… I was programming like usual. Doing my tweaks before my gig last night. And when I started it up on stage, it just kept crashing. Luckily it worked on the 15th or so try and I was able to play the gig. But… there are Neutron 3 plugins all over my patches. I’m using it as a zero latency limiter. I didn’t add any instances of Neutron for many months and it’s been working fine.

I added one more patch yesterday. a single instance of Omnisphere. nothing fancy.

  1. I’m using a ipad running OSC Pilot. I make buttons and faders and they control gig performer through OSC. I put some screenshots so you can see what I mean. I don’t really use the streaming audio player. I don’t know what that’s about.

Any chance OSC messages were being sent to GP while it was still starting up? GP is supposed to have protection from that but maybe there’s a funky issue going on there.

I have not heard of OSC Pilot.

No. I couldn’t have been that cuz I unplugged everything including the iPad and tried starting GP and it kept crashing.

Disabling the Neutron 3 plugin worked for me though. I just bought the plugin Blue Cat Protector 2 (zero latency limiter) and I’m replacing all my Neutron 3 instances. I’ll be fine now.

It’s probably worth reporting the crash to the developer