Crash when using midi fighter twister to adjust master trim

I am relatively new to Gig Performer and am enjoying the product so far. Please forgive me if this is not the place to submit crash reports but I did not see a more obvious place. I am running into a crash when attempting to adjust master trim via a widget which is linked to an knob on my MIDI Fighter Twister. Below are the steps to reproduce and a crash report log:

  1. Added a slider to the global rack space
  2. Assigned the slider to the System Actions plugin, mapped it to the Master Trim parameter
  3. Mapped the slider to my a MIDI alias in my rig manager which is associated to a MIDI Fighter Twister knob
  4. Tested the slider manually by dragging it up and down in value with my mouse. This works fine and the trim was being adjusted.
  5. Tested the MIDI Fighter Twister knob, the value starts to change and then crashes very quickly.
  6. After restarting Gig Performer, odd low end noise is heard until I reset my audio engine via the panic button.

Please let me know if there is more information which could assist in diagnosing the problem.

Have you had the crash when mapping the widget to any other plugin parameter?

Can you try linking the midi fighter knob directly to the master trim via the Options menu bar > Global Midi

Previously I had the slider mapped to the built in Gain plugin and that was working fine with the MIDI Fighter Twister’s knob. It was also mapped to the same alias. I ended up getting rid of the Gain plugin when I decided to route audio to different outputs on my audio interface and could no longer funnel a bunch of channels into a single master gain plugin.

I was able to map the master trim to the same MIDI alias in the Options → Global MIDI section and it worked fine without issues. Thank you for that suggestion. To test my sanity, I then removed that assignment, remapped the slider back to the same MIDI alias, set the plugin to System Actions with the Master Trim parameter and tried it again. It crashed right away.

Just tried to reproduce, was not able.

Can you upload a small gig file, so I could check with that.

I created a brand new gig and made it pretty bare bones but the issue still happens per my original report. Attached is a new crash log and a gig file. It did seem to take a bit longer to crash with the fresh gig file, it seemed to allow me to move the slider to min and max before it crashed this time. That might have just been a coincidence though.

I cannot reproduce, works fine, no crash

Have you checked what kind of message(s) your midi controller is sending?
Maybe there is something wrong with that?
Open the global MIDI monitor, turn that knob and see what’s coming in…
Just to narrow down the possibililties for failures.

Also, you probably should not use a “MIDI OMNI” Block and have the “Midi Sync” option of the fader widget enabled… this is something you could try as well. (Just a shot in the dark)


Both of these crash reports suggest that the problem is with the graphics processing — GP is requesting that CoreGraphics draw something and that’s causing the problem.

We’ve seen a few other reports of problems with graphics drivers

I just verified that my MIDI Fighter Twister is sending what seem to be standard messages. Using the MIDI monitor I saw it sending “CC 15: 125 Channel 1” to “CC 15: 0 Channel 1” while dialing the knob all the way down. Then “CC 15: 0 Channel 1” to “CC 15: 127 Channel 1” while dialing the knob all the way up.

Thanks for the tip about the OMNI block. On my main gig file I have dedicated MIDI in blocks mapped to MIDI Device Aliases in rig manager. The one I attached here was just a quick and dirty way to test and isolate the problem.

1 Like

I attempted a bit more diagnosis this morning with no positive results. I removed my USB C display adapter from the equation and ran directly off the Macbook Pro built in display but the result was the same.

The odd thing to me is the widget’s on screen control works properly when assigned to the master trim via the System Actions plugin even when it is mapped to a MIDI Control (via an alias or directly). The MIDI Fighter Twisters level properly reflects what is being adjusted on screen. As soon as I attempt to use the physical knob on the Twister it crashes shortly after. This has only seems to happen when I assign a control to that specific plugin and parameter. Other plugins/parameters operate fine when controlled from the Twister. If it was a problem with graphics drivers, would the on screen control for the widget be functioning fine?

Since this is a mac my options for driver/OS updates are pretty limited. I’m already running the latest MacOS(14.3.1) I can excluding beta releases. Are there any other troubleshooting steps you would recommend?

Thank you all for your assistance in trying to get this resolved.

To rule out the MIDI Fighter Twister causing the problem I hooked up a Behringer X Touch mini and mapped that to my master volume control alias in rig manager. Then I attempted the same operations and the same crash happened.

Here is a screenshot of my rig manager in case that helps in some way. This screenshot was taken before I hooked up and tested the Behringer X Touch mini: Dropbox - GigPerformer Rig Manager - Screenshot 2024-03-05 at 9.25.52 AM.png - Simplify your life

If you turn off the “Sync” option, does it still crash? I don’t have a twister handy but I did add a knob, assign it to MasterTrim in system actions and then learned that knob from a slider on my controller but I can’t crash it.


The sync option does not appear to effect the crash. I’ve tried both the Twister and the XTouch Mini with sync on and sync off, the crash happens regardless. I tested from both a local rack space and the global rack space but the behavior is the same. I can happily adjust the master trim via my widget on screen without any issues. When I attempt to control that same widget via a MIDI control(learned or an alias), GigPerformer crashes within a few seconds. The time it takes to crash is somewhat variable but it never lasts more than about five seconds. Usually the crash is near instant.


Do you use a Mac with an AMD graphics chip? Lots of users reported some weird behavior with these chips.

Nope, mine is a first generation apple silicon. Here is some info from my system report:

Hardware Overview:
Model Name: MacBook Pro
Model Identifier: MacBookPro18,3
Model Number: MKGP3LL/A
Chip: Apple M1 Pro
Total Number of Cores: 8 (6 performance and 2 efficiency)
Memory: 16 GB

Apple M1 Pro:
Chipset Model: Apple M1 Pro
Type: GPU
Bus: Built-In
Total Number of Cores: 14
Vendor: Apple (0x106b)
Metal Support: Metal 3

I see you are on Sonoma, maybe the most buggiest macOS. You can see lots of threads like this where people complain about various OS-related stuff.

Is there any way to revert to Ventura?

Yes, I’m on the latest public release of Sonoma. I’ve not experienced any issues with this version of macOS in particular but that does not rule out the possibility this crash being Sonoma related. Once all other options are exhausted I may try a complete refresh of the device back to the latest release. If that fails, then I’ll attempt to revert to an older version. Either of those attempts will need to be planned and scheduled since they take a fair amount of time and the device is also used for work. macOS 14.4 is just about to release so I’ll give that a go as well before I try more drastic measures.

I have multiple work around solutions for my needs thankfully so I’m not in dire straights to get this issue fixed. I ended up just routing all of my outputs through a mixer in the global rackspace, created a widget group of hidden faders and control those from a master fader.

Thank you all for you time on trying to diagnose this issue. I’ll post more details if I figure anything else out or am able to resolve it.

I just tried your gigfile and building my own gigfile with mapping any knob or slider control control to the Master Trim level via the System Actions plugin (in both the Global and Default rackspaces). There is a crash every time.

I am also in Sonoma 14.3.1…this must be the problem. And, as far as I can tell in testing, the Master Trim adjustment (within System Actions) is the only function in which the crash happens.

So, unless we can revert back to Ventura…Don’t do that.

1 Like

Thank your for taking the time to confirm the issue. At least I know I’m not crazy now!


Please see my private message to you

1 Like