Controlling external FX processor

Hey guys, it’s been a long time since I last had any ‘issues’ with getting around GP, but I guess I have one of those ‘moments’ and I need someone to bring me back to my senses.

I’ve recently bought an FX processor which I’d like to have some basic control over, like to bypass it when I need to talk, and change banks and presets.
Basically I want to assign a button on my MIDI controller which is connected to an audio interface via USB MIDI cab;e which I use to control the VST’s I use in GP, and I have connected the 5pin din MIDI OUT on the audio interface to the 5pin din MIDI IN on the FX processor in order to send the necessary CC’s from GP to the FX processor.
I’ve been bashing my head a good couple of hours without any success. Can someone guide me what would be the right way to do it, please?

All the best,

What is the CC number and values required to bypass/unbypass the processor?

  • Add a MIDI Out block for your audio interface (which has the processor connected to it).
  • Add a button widget.
  • Map the widget to the MIDI out block, and you will see there are parameters for each CC number.
  • Choose the one that your processor needs to bypass/unbypass.

I use this approach to control my external MIDI-controllable guitar pedal switcher, and it works well (controlling it from another MIDI pedal or via variations).

Thanks @rank13,
That’s what I was doing wrong, I was assigning MIDI OUT on the MIDI controller, and not on the audio interface for some reason. According to the MIDI implementation chart I have to send CC 113 with value 1 or 0 for on/off. I’ll try again when I get back home in few hours and get back again with the result.


To get it to toggle between 1 and 0 you can use the widget scaling curve on the ‘Value’ tab.
If you edit the ‘Max’ value and enter “1m” it will convert that to the value needed to send CC value 1 when the button is clicked.


Thanks a bunch @rank13!
Everything works as expected now. Although I had to fiddle with the MIDI settings on the processor because for some reason OMNI was defaulted to Off so I had to switch it to On, CC specific channel was also set to ‘Off’ and I assumed it would accept MIDI CC’s from any of the 16 channels, but it appeared that it won’t receive nor send MIDI at all, so I had to set a specific channel for MIDI IN…anyway, it works now!

Best wishes, and happy holidays!

1 Like

Glad it worked. I couldn’t tell if you saw this option, but if you open the MIDI Out block in GP, you can set a specific channel for the outgoing messages.

If you ever had another external midi device connected to your interface, you can then add a second MIDI Out block and choose a different channel for it (also renaming the blocks so it’s clear which is which).