ControlChangeEvent callback not called when receiving CC events


#1

I started to write a script receiving the pedal events of my piano controller (CC67, CC66, CC64). I have got a callback function which is supposed be called when receiving one of these events. Whatever it does for the moment, the first function of this callback is to print out the CC number received in the script logger window. For CC64 no problem, but for CC67 and CC66, nothing appears in the script logger window, while I can check in the MIDI monitor that the MIDI events are received.

I am tired these days, so I would appreciate if somebody could tell me what I am missing.
The corresponding gigfile is here: CC_Switch_test.gig (11.3 KB)
I have another issue with this gigfile, when I open it in GP and then close GP agin. It crashes during closing!

Here is also a screenshot taken just after I pushed successively the CC67 and CC66 pedals. The CC events appear in the MIDI monitor but not in the script logger window:


#2

An obvious thing to check first is to see if CC66 and CC67 are used elsewhere - e.g. Globally assigned to something or assigned to a widget maybe?


#3

Neither CC67 and CC66 nor CC64 are assigned to any widget, that’s not what I wanted to do. Is it mandatory to assign these CC to a widget ? I don’t see exactly understand why it should…

By the way, the callback works always for CC64 and sometimes, but very rarely for CC67 and CC66. (I mean the first “print” is executed)


#4

@djogon OK I understood what you wanted to explain to me. it was a global assignment to the Previous/Next Rackspace switching in the Global MIDI assignments. I told you I am tired :sweat:

Thanksđź‘Ť


#5

The callback function works now for me, but when closing GP with the gigfile I uploaded above, it still crashes :confused:


#6

This is almost certainly related to a plugin you are using. Make sure you update them all. IF you want to isolate which one is responsible you will unfortunately have to remove them one by one and then shut down and see which one is the trouble-maker.


#7

This is a new empty rackspace without plugin with just a widget button and a script.


#8

Are there other rackspaces in the gig file?

What happens if you hold down the SHIFT key while loading GP (this will start with a truly empty gig file) and then you quit?


#9

If have only the issue with the uploaded gigfile. It doesn’t happen with any other.
NB: I started this gigfile from an empty one, there is only the default rackspace and the default variation, one widget button and one script.


#10

an’t reproduce this. Tried many times. What are the exact steps that you are performing? I tried fiddling with things, then quitting, tried just opening and quitting etc. but I never get an error.


#11

Opening and quitting and crashing !


#12

Very odd. Possibly a driver issue on Windows - either midi or audio. Try to double check if you updated all the drivers. Also - what happens if you install ASIO4ALL drivers and try to use those?


#13

My RME drivers are updated and I just tested with ASIO4ALL and it is the same : open, close, crash !

Could I have exotic preferences ? Is there a way for me to save my preferences in file for you ?

I just tested started GP with the ALT key pushed, and no crash when closing. When starting with ALT, If I compile the script and close GP, It crashes !!!


#14

Ah… that’s a big clue. Thanks. I now had something to go on so I was able to figure out what’s going on. Very peculiar case, but it will get fixed in the next build.
THANK YOU!


#15

I will do my very best to find you other very particular cases :wink: