Connection to Amplitube gets lost

I would like to use the Wah Pedal from Amplitube (V 5.7.1) within GP (V4.8.2). For that I created a knob widget in GP and connected it to Amplitube Wah parameter via the DAW automation parameter assigment from Amplitube (+ via Midi to the Wah pedal). No other stomps/pedals in Amplitube, just one single amp.
When GP ist started, everything works as expected. However when moving the widget quickly + repeatedly from 0% to 100% and back (approx 2Hz), the connection between GP and Amplitube seems to get lost, Amplitube is not modifying the sound any more, it ist ‘stuck’ in one position. Interestingly, as well any GP widgets assigned to the Amplitude amp have as well lost connection (+ even more strange: in the Amplitube window opened from GP the wah pedal and the amp knobs are still visually moving, however the sound is not changed any more).
The above is 100% reproducable on my side, occurs sometimes directly with quick widget movements, sometimes it takes 20 seconds movement or so. Only chance to get again ‘connected’ to Amplitube is to restart GP.

Looks to me like an issue on the Amplitube side - however I wanted to start asking here if someone has experienced that as well and if there is any workaround. (Please don’t tell me just to be more hesitant with the Wah pedal… ;-))

Can you please try with a different plugin format? If you tried with a VST, try with VST3 or vice versa.

Sounds like a race condition in the Amplitube plugin.

On my Dell that seemed to pretty much always happened when I moved a widget fast I think no matter what. ( I don’t tweak widgets in real time much. So, I don’t know if this is still an issue with my new, more powerful computer).

With Amplitube or with another plugin? Moving a widget directly or doing it over MIDI?

Over midi with a controller. Not with Amplitube. I figured it was because of my underpowered computer.

Wow npudar you are a genius!! :ok_hand: :metal: :+1:
Switching over from VST3 to VST seems to have solved the problem (at least I was not able to reproduce the issue within 15 minutes heavy moving the knob widget/pedal).
Thanks very much - I would never have guessed that this could solve the issue…
Just out of curiosity: is there any rational why going from VST3 to VST solved the issue…?
But: I am just happy that it works… mabe better not to ask why :wink:

1 Like

I kinda have a nose for these things :slight_smile:

I got this feeling that developers struggle a bit to implement VST3 plugins properly. Take a look at this thread, for example: [blog] How to find out which plugin crashed Gig Performer - #26 by npudar
→ Mostly bugs in VST3 plugins are fixed.

Anyway, I’m glad that you solved your issue. Keep rockin’ :beers:

1 Like

Think about it the other way around — VST3 is a newer format that Steinberg has been trying to push on everybody for some time. The VST2.4 version has been stable for many years and developers have had plenty of time to solve issues.

So it’s not that going from VST3 to VST fixed things but rather, going from VST to VST3 is what broke things.