Clicks and pops


I am having difficulties making a free of clicks and pop sound in gig performer.

I am using kontakt 6 ver 2.2 as my main source of sounds.

I tried uploading 8 instances of kontakt, 4 of them are loaded with spitfire chamber strings (violin 1 violin 2 viola cello) and 4 more with Berlin woodwind ( flute 1, flute 2, clarinet and bassoon) all of them using the legato patch.

That’s a total of 8 instruments.

Playing more then 1 note at the same time couses intense pops and crack sounds.

Fast runs make instruments to get stuck. I can reset it only by deleting gig performer.

As a reference I used cubase10.5 as a vst host and loaded the same instruments:

No cracks is heard even when 8 notes are played simultaneously .

No problems playing fast runs.

I tried this on 2 computers:

1: desktop, windows 7 64 bits, 32 GB ram, 500GB SSD system drive,libraries on external 7200 HD on USB 3, I7 processor, Audio card: RME fire face 800, optimized for audio performance, All driver Updated

2: Laptop, windows 10 64 bits, 32 GB Ram, I9,1TB SSD system disc, libraries on external SSD disc over USB C (3.1), Audio card: Presonus studio 1824C.

Both computers are audio optimized ( including power saver schemes , performance profiles etc) ,and all drivers have been updated.

I use 44.1 Khz sampling rate and a 512 samples buffer size.

Task manager shows about 30% of memory usage and about 9% of CPU load on laptop.

The result is always the same and reproducible.

I would appreciate very much any help suggestions.

Thanks so much

Doron Tovim

The Spitfire Audio libraries seem to be very CPU intensive. I haven’t had any luck using them live.

I have NI Komplete 12, so I think if you upload your gig file, I could test it with a 3Ghz i7 running Win10 and an RME UCX audio interface.

Did you play in realtime from your midi controller or did you use a midi track?

I use my MIDI keyboard since I do mostly live performances.

Hi David,
I tried to load the gig file but this blog would not allow me since I am a new user.
Any way, the configuration is quite simple:
8 instances of kontakt 6, each load with some sort of instrument that activates at list 3-4 voices for each sound .
I use spitfire chamber strings for all the strings sounds and Berlin woodwind for all the wood wind sounds.
The instruments are: Violin 1, Violin 2, Viola , Cello, Flute 1, Flute 2, Clarinet, Basoon.
An omni MIDI is connected to all instruments and all instrument connected to the same out of the sound card.
That’s it!
Play 2 sounds at the same time and the pop sounds come up immediately
Do you get the same result?

I’m using a pretty fast computer ( I9 and 32 Gm of Ram with a SSD disc)
so I get a low cpu load ( about 9 % at most according to windows task manager). So this is probably not the problem.

OK, when you play all your notes needed and do “purge Samples” in Kontakt, only used samples should remain, what happens then?
And try to reduce the sample buffer to 256 Samples, sounds strange but I faced situations with other DAW’s where reducing was the solution.

OK, we know you now :wink: You can try again…

OK. Here we go…Strings & WoodWinds single midi.gig (3.7 MB)

I see you loaded 8 instances of Kontakt 6.
What happens when you just load 2 Instances of Kontakt and build multis within Kontakt with Multi Out?
So you can user your mixers like you do with single instances.

Did you enable Multiprozessor Support in Kontakt?
Bildschirmfoto 2020-05-31 um 11.46.50

My Komplete was not that complete! I had to replace your libraries which are not included in Komplete by Strings and Woodwind Synphonies:

Strings & WoodWinds single midi.gig (7.8 MB)

So at 44.1KHz and a buffer size of 512, no problem here, but I did’nt use the exact same libraries than yours.

For me, a buffer of 512 is a no go for playing piano and my buffer is usually set at 256. So I reduced to 256 and my 4 cores i7 @3GHz with 16Gb RAM and an internal 2Tb SSD, started to have glitches.

I then opened four GP instances and loaded my version of your gigfile in all the instance. I then removed all the plugins but two of them in each instance. It ended up with:
GP instance #1: Violins I + Violins II
GP instance #2: Violas + Cellos
GP instance #3: Flutes I + Flutes II
GP instance #4: Claninets + Basson

So, using 4 GP instances with my “small” PC, I could finally play all the instruments without any glitch.

Hi David.
Thanks so much for your efforts to help!
I also tried a few things, inspired by the Gig community.
Here are my finding:
The problem is not in Gig performer after all, it is probably neither in kontakt.
The libraries I was using were loading kontakt very much.
In fact each note ( played just once and held) takes up to 4 voices.
The voices are still used even if you let go of the note, until it fades completely, it might take several seconds…
So if you play a quick run of fast music it builds up.
Multiplied by some 6 notes chords one can easily get to about 250 voice X8 instruments.
This is probably to much for the humble kontakt.
I will have to look for some more voice conserving libraries.
thank so much for you r support

Do you experience the same issue with the libraries I used in my modified version of your gig file (if you own them)? (I just noticed the gig file was not attached to my preivous post, but it is now…)