Bug with output meters with test tone plugins in global rackspace?


In the global rackspace I inserted a Waves EMO-generator plugin and wired it’s L+R outputs to 3x2 output channels of my RME fireface, to enable easy gaining of the FOH mixer towards the reference tone.
Inserted a panel button to switch the plugin on/off. Audio is doing fine on all six channels.
In the global rackspace I also have 6 output meters for my visual monitoring and my basic stereo piano setup. All my synth sounds are fed from their respective rackspaces to the global rackspace through the ‘from rackspaces’ blocks, to apply bus effects and final compressor/limiting.

Now the unexpected behaviour:
When having only the Global rackspace loaded, the output meter widgets only display audio 1 and 2 initially when I switch on the tone generator. After switching back and forth the globe button, all 6 meters display correctly.
This issue also arises with a different brand of audio plugin source.
Could this be a bug?

How do you do that?

What is the globe button?

Can you show some screenshots?

Hi @menm, welcome to the GP community forum. :wink:

I agree with @pianopaul, a screenshot of your wiring view and perhaps of the corresponding panel would help to follow you. You can also post your gig file for us to be able test further.

@pianopaul , @David-san
Sorry! Wrong mouse click, deleted the thread. Retry.

When using either testtone-generator plugin (tried multiple) connected to the interface outputs in the global rackspace, audio level meter behaviour is unstable. Sometimes all dead, sometimes over time (15-30 seconds) some come alive, sometime all alive when initially enabling the tone output.
When switching back and forth between global and local rackspaces (with the globe button in the top left corner) all display as expected.
In all cases, the green output LEDs in the bottom right corner all light up as expected.
Behaviour seems independent of instrument plugins present in the local rackspaces and routed to the global rackspace through the ‘To Global Rackspace’ block.


No audio level metering
When enabling the test tone initially

Correct audio level metering
When switching back and forth between global and local rackspaces.

What happens if you put a mixer block before the final audio out and learn the meter widgets to this?

Same issue.
The audio meters within the mixer plugin behave equally unstable; as a result the derived metering in the panel also.

Hmm… since the Waves plugins don’t have a good reputation for the use in Gig Performer and just for completeness’ sake, could you try another signal generator, i.e this one?
MNoiseGenerator | MeldaProduction

1 Like

Yes, I did.
Same behaviour.

1 Like

To be clearer:
The Melda oscillator AND other plugins with a 1kHz tone give the same unstable behaviour.
Now tried the Melda noise generator as you suggested, and that one seems to be working OK.
Makes me get deeper…
Using the Melda oscillator below or above 1kHz works OK. Only on exact 1kHz modulation, behaviour is unstable!
Wonder what explanation can be given form software development perspective :wink:

This is weird… :crazy_face: looking forward to what statement @dhj will give.

This is an RME interface yes?

Without seeing a video of the behavior in action, or a view of your meter widget mapping in the editor… I’m not sure but a couple of guesses…

Have you tried changing the physical scale of the widgets themselves and see if that improves the re-draw accuracy?

Since you are applying to the RME outputs themselves and not a mixer block (although you said you tried that too) is it possible that the RME is just not sending the meter data back accurately?

Is there any chance that wtihin the RME software you are multiplying the outputs by themselves causing phase cancelation? Your 1 KHz tone phenomonon makes me think it could be that.

Can you reproduce the 1KHz tone issue using the meters mapped to gain stages before the interface outputs?

Is this just a display issue with the meters? Are you hearing all sound properly?

If you perform this setup completely in a local rackspace (forget the global rackspace completely) does it work?

Thanks for your reply all!

It is just a GP meter display issue. Sound is good, and bottom right hand output LEDs light up.
Same issue in a new gig file with local rackspace.
Please check attached file (using free Melda MOscillator)

Changing widget physical scale makes no difference.
Using a mixer block has the same issue. Separate gain stages (no outputs connected) also.
Phase cancellation was ruled out. Also no audible audio issues.

1kHzToneTest.gig (101.2 KB)

I can’t reproduce the issue with the test gig you sent. I don’t have the same interface but wtih my MOTU M4 this works with no issues.

I don’t have MOscilator I use SocaLabs ToneGenerator which outputs mono so I just wonder if you try that (free) version or you run your oscilator mono vs. paired outputs… do you get any different results?

1 Like

Hm, I must admit that I did run in the same kind of trouble with these ‘Vu-meters’ (the display just freezes while the audio, my guitar, is really not at the same level all the time), but that gig-file was rather complicated and also more or less a prove of concept, so I never thought of reporting it.

I’ll see whether I can still reproduce the problem or not and, more important, if there is a reliable way to reproduce it.

Btw: I’m on Windows

Yes, I tried with SocaLabs ToneGenerator as well. same issues.

When i asked for using a mixer plugin, i meant it like this
2023-04-03 17_09_09-Window
The output pairs mapped to 1/2 3/4 5/6 7/8

and then having the meter widgets connected to the meter parameters of the mixer (not the audio out)

Maybe you also should try the VST/VST3 format of the plugin instead of the AU… worth a try anyway since we experienced the diffrent formats to behave diffrently quite often (also better for interchageabilty between the two systems).

This is the gig file i made for this (on Windows = VST)
1kHzToneTest_Mixer.gig (109.5 KB)
(EDIT: The frequency wasn’t set to 1kHz in the gig file - please re-load)

1 Like

OK… i can reproduce this - even on Windows and using the VST format plus (only) virtual output channels (via ASIO LINK PRO).

But it really “only” seems to be a graphical update issue… as soon as you add another rackspace (may be empty) and you switch between the rackspaces, the meter widgets will be updated and work as they should.
And it really only happens if the Oscillator is set to 1kHz. Crazy stuff! :crazy_face:
BTW i run audio at 48kHz if that should matter?!

But using a mixer before the final output and conecting the meter widgets to the mixer’s meters does work… this might be at least a workaround.

Unfortuenately not true… i forgot to set the frequency to 1kHz when i tested it.
So, the issue persists!

1 Like