B4II Organ with JBridge

I started out very happy that GP was working fine with my “go to” B4II Organ (with JBridge to run this 32bit VST in GP).
But on day two of building rackspaces, now when changing a setting in B4 it seemed to consistently result in the B4 interface not closing right away, then when I reopen the B4II to try to edit, it is just all white where the B4 graphics would normally be.
I hope there is a trick other than closing and relaunching GP to get the B4II interface back.

We don’t support 32-bit plugins at all. If you use something like jBridge, then you’re completely at the mercy of whatever jBridge does to manage plugins that it loads. You’d have to talk to the jBridge developer. As for B4 II, even Native Instruments hasn’t supported it for years

You’d be far better served to switch to a modern 64-bit organ VST such as Blue3 or VB3.

I actually had a similar problem some years back (working with Forte). I did contact the jBridge guy and he had some suggestions for changing some settings in jBridge, none of which worked as I recall… but he was responsive. I have this vague recollection that I did resolve it somehow…if it comes back to me I’ll let post again. Sorry! You could try this… https://www.kvraudio.com/forum/viewtopic.php?t=395171

But yeah better solution is to go 64-bit. I just recently finally let go of a favorite patch in Pro53 and no longer use jBridge. I liked B4 a lot for its time, but I couldn’t work with the distortion in B4II. But the new crop, Blue3, VB3 and B5 are amazing. There is a free 64-bit B3 that isn’t horrible, AZR3 https://blog.wavosaur.com/7-free-vsts-for-hammond-b3-emulation/

I was originally having completely stable performance (actually for weeks) with B4II and so I was just sticking with it (thinking… if it’s not broke, don’t fix it). In computers, I don’t get why software works, and even with no changes to the system, the same software starts to misbehave.
But I agree … Blue3 will be my next purchase for B4II replacement.
(Fortunately VSampler still works with Jbridge in GP, but I can see I will need to continue my Kontakt training, and eventually ditch my beloved VSampler)

We refer to that phenomenon as bit rot as we’ve all experienced it.

But in reality, there’s no magic. Something had to have changed. But sometimes it can be almost impossible to figure out what did change,

Dougalex,

My guess is you must still be on Windows 7, or you have an older, specific build of B4II. I ran into issues running the latest version of both B4II and Pro53 on Windows 10. Apparently some users that had older builds of these plugins actually got them to work on Windows 10, but I did not have those particular plugin dlls and having somebody else distribute it to you would violate the terms of the license.

If you’re still running Windows 7, don’t wait too much longer before migrating your rig to Windows 10. Windows 7 will stop getting security updates in January of 2020. It was the move to Windows 10 that further motivated me to switch to Gig Performer from Forte. I just couldn’t get Forte to run with any real stability on Windows 10.

X

Sine 2017 I have been using a top-of-the-line pcAudioLabs laptop running Windows 10 with multiple Solid State drives, 64 gb RAM.
B4II (via JBridge) worked fine in Forte, and, at first, worked fine in Gig Performer. Then for some reason B4II started to freeze up whenever I changed parameter from inside B4II interface. I got clever and assigned widgets to make changes without opening the B4II interface.
But B4II issues will be moot this week, as I am definitely now going to use a 64bit hammond organ (probable choice right now: Blue3).

And… Yes, I “lived in fear” using Forte on stage :astonished:

Did you by any chance use the NI Service Center and perform an update on B4II right around the time the problems started happening? Just curious…

X

1] My issue was probably not coincident with that
2] Beyond that, my recollection is, B4II just shows “out of date” (or “can’t locate”) in NI Service Center, but there is nothing you can do about it.

I’ve had it happen before where the bridged plugin gets in a weird graphical state and then it gets saved in that state. Mess around with the jBridge GUI parameters, and you’ll find the solution to your issue.
j

I tried changing some of those options as suggested on JBridge website and it made it worse, so I got spooked and put it back… and never messed with it again. Maybe next time there is a long spell between gigs, I might try again.:thinking:

I love that last option, “I am getting an opcode 19 error”

I really think you’d be better served by switching to a native 64-bit organ plugin

1 Like

I also have B4II jBridged in my Windows 10 machines. Mind you that I said I “have” not “use.” I remember having a similar issue before, and I think I reinstalled it and it solved the issue. I fired it up in GP 3.27 just now, changed a few things in VB4II, and the GUI opens up just fine.

Of course, now that I think about it, all of my tests with B4II/jBridge on Windows 10 were done in Forte over two years ago. I have never explicitly tried B4II with GP. Of course, I’m not going to at this point as to me that would be a step backwards. I completed my move to only using native 64-bit plugins live about 18 months ago.

X

1 Like