Auto Sampler: Questions & suggestions

I had a great afternoon trying out Auto Sampler for the first time. After a break of almost 3 years, I’m going to play some gigs with one of my bands, which is great fun. For this project, I want to sample some layers of different instrument plug-ins, with splits and different transpositions. It’s very intuitive and works exactly as I expect it to. Fantastic feature!

Here are some suggestions:

  • When I press the “…” button next to the output folder text field, the folder selection dialog opens, but it defaults to a fixed folder (Gig Performer/AutoSamples), not the folder in the text field. So I have to manually navigate to my custom folder every time I want to select a different subfolder. Also, the text field can’t be edited manually. So this was a bit tedious. It would be great if the text field was editable and/or the dialog always showed the text box folder first.

  • The minimum value for the Note Length is 250 ms. But I’d like to sample very short synth plucks and synth pizzicato notes so I’d like notes even shorter than 250 ms. By using the “calculate using BPM” option I can achieve 100 ms, so there’s the workaround :slight_smile: But could the min value perhaps still be set to 100 ms?

  • It’s a very nice feature that you can click on the highest / lowest note labels to hear a preview. I’d love to have that for highest/lowest velocity and the note length as well (to figure out how short my synth plucks need to be to be captured the way I want to play them later) :upside_down_face:

And a question:

I have a Rackspace with two MIDI in blocks (same MIDI input device) that have different ranges set (“keyboard split”). I was wondering what would be the easiest way to capture the entire Rackspace exactly as it sounds when I play it on the keyboard.

Maybe I am missing an already possible workaround? Maybe using GP Relayer (I haven’t tried it yet) and sending from GP to GP?

Thanks for any input! :slight_smile: And again, it’s a brilliant feature and I love it!


What’s stopping you from doing that?



Now I was momentarily baffled why there are input pins on your screenshot. I must have forgotten that the “Enable MIDI Merge” option exists.

Of couse that’s the solution. Thank you David!