Audio stops Responding

I’ve had the same issue occur during my last two shows and I’m a little stumped on how to troubleshoot and resolve. This happened with both GP 4.8x (first time) and GP 5 (second time). I just did my upgrade a few days ago and this issue did not present during my extensive pre-show testing.

In the middle of a show, the audio simply stops producing out of GP. I can still navigate back and forth between songs/rackspaces, but the only way to get audio back is to completely quit GP, restart it and reload my gig file. Given that is a 3-5 minute load time, that is really not a good pattern and I have to get my band members to stall while I get everything reloaded. In both cases, the problem did not present a second time during either of these shows.

Configuration:

MacBook Pro 2021 with M1 Max, 64GB ram, 1 TB SSD
Behringer XR18 mixer/audio interface
Nord Stage 4 (connected via USB)
NI Komplete Kontrol S88 (connected via USB)
Panda Midi MidiBeam wireless (connected via USB)

One thing of note, back in the old days when I was using Brainspawn Forte on PC, there was a button on the main panel (always visible) that you could use to turn the audio engine of Forte on and off. I did experience this type of issue very occassionally with Forte, but I could use that button to specifically turn off and on the audio engine which would solve the problem without restarting Forte and reloading my show.

thanks,

X

What upgrade?

You are using a plugin when this happens? What plugin?

Jeff

I think double clicking the panic button resets the audio interface. Single click is your typical midi panic.

2 Likes

Yes double click resets audio system

That said, there is no magic here. If everything worked fine on your tests (though a couple of days is not a lot of time to do thorough testing if you did an os update) then the most likely issue is hardware, maybe a cable or USB.

You can add a System Actions plugin to your Wiring view, add a Pad widget and assign it to the Panic parameter. Double-clicking that button (or double-tapping, or hitting the key/button on your MIDI controller/Touch surface twice, or even the Stream Deck configuration is available) will reset the audio system.

If I were you, I’d:

  • update my drivers (if available),
  • check the cables,
  • check the USB hub,
  • possibly leave your configuration for hours at home to try to test would it happen again.
1 Like

Thank you all for your feedback. My plan is the following.

  • Change out my USB hub and cable to the audio interface (I already have matching ones in my home rig)
  • Make sure I have a button somewhere I can tie to a widget in the global rackspace for hitting the panic button so that I can double hit the panic button if and when it happens again. I already have a stream deck that has been setup for video work, but I can retask that to my live rig
  • Once we have a longer break, spend some time writing some type of scripting to run the whole rig through load for several hours to see if I can reproduce outside of a live situation

WRT to upgrades, I upgraded the OS (minor update from 12.7.4 to 12.7.5 early in the week and tested with GP 4.8x with no issues. I upgraded GP itself from 4.8x to 5.x mid-week and continued testing with no issues.

Since I was in the middle of a show, I was unable to take notes while trying to recover from the audio stopping in the middle of a song. I’m going to take the extra 10 seconds to make notes if and when the issue occurs again.

X