Audio optimization


I’m on Windows 7 and was just wondering what audio optimization tweaks are recommended. I have followed the advice of a couple of websites and

However this guy on Steinberg board claims many of those tweaks are counterproductive and has his own recommendations

I am asking primarily because since I started using GP I can not get my ASIO buffer size to 64 samples without a bit of crackling. I did not have this problem when using Forte previously. The only thing to change was that I added Amplitube… and while I know that is a cpu hog, it shouldn’t effect racks it is not in should it? I do not have predictive loading enabled.


I think you’ll find that you don’t need to set the buffer so low for effective use in GP. I have mine set at 128 for live use and there is no problem with audible latency.


I use 256 buffer size myself and have not had any issues (including with percussive acoustic piano). It’s also worth reading Nebojsa’s article about latency


ok, I;m at 128… and it’s ok. For my Scarbee Vintage Keys and ep88s in particular it is definitely too sluggish for me at 256.It really is a matter of feel for me and yes I most definitely can tell the difference… I could be wrong but I think I could tell it felt better at 64. I’ll play around with that more at some point.

But my main question was what optimization tweaks do people confidently recommend? Does anyone agree with this guy that many tweaks are counterproductive?


Other than some obvious things (turn off antivirus, schedules tasks, other applications and so forth) probably the best way to improve latency is a better audio interface.

You don’t mention what interface you’re using but there can be really significant differences with different interfaces.

See for example this


Right I use an Echo Audio Indigo express card. It is a high quality interface., i love it because it just stays plugged into my laptop and is not another thing to carry around and plug in etc. .As I said, I never had any issues with it when running Forte at 64 samples.


Did you have Amplitube in Forte?


No I did not,I realize that is a big difference. I mentioned that in original post and was asking if that should effect GP racks that Amplitube is not in? I do not have predictive loading enabled


If Amplitube is not in the rackspace, then it won’t have any effect on CPU usage.

Have you run the GP Measure Device Latency tool? I’m curious to see how much latency is being added by your audio interface. Something is amiss if you can tell a big difference between 64 and 128 samples.


I didn’t know there was a Measure Device latency tool, but will check it out. I didn’t actually say there was big difference between 64 and 128 samples… but did say there was a big enough difference between 128 and 256 for me, so that I could not really use 256. And I said I thought I noticed some difference between between 128 and 64 but was going to investigate further.

In regard to Ampitube, I was getting crackle at 64 samples in rack spaces that Amplitube was not in… so will investigate that further as well.


It depends. Gig Performer shuts down all audio processing of plugins that are not in active rackspaces. Well behaved plugins shouldn’t be doing anything else when they’re not processing audio. However, some plugins spawn off other threads and do (who knows what) stuff with them continuously and such plugins will certainly suck up some cycles unnecessarily. I can’t say whether Amplitube is implicated at all.
Finally, just because something claims to be running at 64 samples, doesn’t mean it actually is. Some programs have an extra “safety” buffer in there that they don’t tell you about


So yeah, I found the Measure Device Latency option, but my interface has only outputs so I can’t measure it. I can assure you it is top notch however, I have been using it a long time with no problems. Echo Audio is great company, but got out of the musician market, unfortunately.

So anyway, I formatted my hard rive and reinstalled everything. I have not done any optimization at all yet and my basic racks in GP that were running at around 7-9 cpu are now up at 15-17. So I will be definitely be trying those optimization tweaks…if I can find time I will try to do it one by one and check cpu each time.

Interestingly enough, tracks that have Amplitude in them were running at 27-29 but are now under 20, even pre tweaks. I updated to Amplitube 4.8, so maybe that’s it… or maybe I’m just not remembering correctly. I wasn’t really paying that close attention at the time.


I have followed these guides for years, and have zero problems with live performance, even with heavy (3.2 MB)


Thanks @magek that looks to be incredibly thorough and comprehensive!


Ok I feel I should acknowledge and apologize here… particularly after making the statement that this didn’t happen in Forte. As it turns out, somehow during all my re-installation, I picked up some malware, so my laptop was running at 50% cpu at idle (must have been mining for bit coin). So that’s why I was having trouble running at 64 samples, nothing at all to do with GP obviously.

I’m sorry! You guys have a fantastic product here and are incredibly helpful and its much appreciated. I don’t mean to jam up the works with my own operator error.

However I found this out at the end of doing all the tweaks in magek’s link above and was going to actually start disabling services ala Black Viper (the manual above also recommended killing some processes… and so that’s where I finally saw 50% cpu)… and my laptop has never run better. I’m at under 5% for most of my racks now.

1 Like