Audio glitches when simultaneously recording 4 tracks


#1

Hi GP users,

I just experienced a very annoying issue trying to record 3 tracks at the same time (2 (L+R) dry tracks and 2 (L+R) with a reverb produced by the DSP of my audio interface). I had random audible audio glitches (“cracks”) recorded on all the tracks. Then I tried to record only 2 tracks, and it went OK.

Any tip for me to track the problem ?

David

PS 1: GP runs on a 3GHz core i7 PC with 16Gb RAM and an SSD (memory usually used <4Gb). My OS is (still) Windows 7 64 bit which is updated. My Audio Interface is an RME UCX with both firmware end driver updated. I have the same issue with Ivory 2.5 American Concert D (streaming samples form the SSD) than with Mr Tramp 2 (model based low CPU plugin). And at the time of my initial setup I followed a tutorial from Cantabile guys to optimize my PC for audio. I don’t have any DAW, just Ivory Cantabile (the Cantabile lite version delivered with Ivory plugins)

PS 2: By the way, why do I have to activate ouput loopback in my audio iterface to record the output of a plugin ? I remember I could record both analog inputs and plugin outputs with Cantabille… I perhaps missed something…


#2

Recording is a very lightweight operation in GP especially with an SSD. I routinely record 18-20 channels on my old 2011 mac running my gig at the same time. Never had a glitch even when recording for hours.

Are you sure that you do not hear those glitches while playing?
What are your Buffer size and Sample rate settings? What is your CPU usage when you play your instruments?


#3

The CPU usage for Ivory 2.5 American Concert D is below 25%, while Mr Tramp 2 + Chorus Ensemble keeps under 15%. My current sample rate is at 48kHz with a 256 samples buffer size. This leads to 5.3ms of delay which is a maximum to me if I don’t want to notice the delay when playing. It can happen that I hear a glitch, but yesterday, when recording, it was awful. Then I jumped to Cantabile where I could record a stereo track without any problem. Then I went back to GP and tried to record also only two mono tracks and it worked without any glitch. I added to more tracks to my recordings and had glitches again.


#4

As I mentioned - very unusual - we must be missing something.
Does your CPU usage go up by more than say 3% when you record and hear glitches?
Does it ever go to over 50%?

It can happen that I hear a glitch…

You should never really hear any glitches. If your CPU is staying at or below 25% the CPU power should not be an issue. If it spikes when you play to a much larger number - you may have a performance issue.

You do not mention your memory consumption. If your memory is running out and your computer needs to use something called “swap” then your disk performance and performance in general will be severely compromised.
If you are running low on memory - try to enable GP’s Predictive Loading feature which unloads unused rackspaces.

There is also a good article written by people at Ableton about optimizing Windows computers for audio. We think they give a sound advice there so take a look and see if you could optimize your system further.

Here it is: https://help.ableton.com/hc/en-us/articles/209071469-Optimizing-Windows-for-Audio

Hope this helps.


#5

My CPU usage varies slightly from a few percents, and regarding the CPU usage, the fact that I record is not noticeable even if I record 8 tracks. This morning I tested again recording 2 tracks only, and it came later on, but I finally had also one single glitch. But from 4 tracks, it comes very quickly. When recording with Ivory Cantabile, which indicates a much higher CPU usage of up to 50% with the Ivory piano, it worked fine when recording a single stereo track (I made tenth of live recordings until my son played perfectly :wink: and I never had a single glitch).

Regarding the memory, I have 16Gb and I usually use less then 4Gb (I updated my original post with these values). The Predictive Loading is not activated in my configuration, and the SSD and the CPU are so quick that I don’t need it for the moment.

I had a look at the Ableton document, I will take the time to read it more carefully, but I think I already followed all the tips when installing my PC. The last time that I had glitches, it came from a shorter faulty USB cable, I had to come back to the original RME one which is a bit too long, but well. When buying a USB cable you unfortunately never know how good it is.


#6

Thanks for the info. Your system certainly looks like it should handle 64 or more simultaneous channel recordings without problems.

Not sure how would your USB cable impact the recording part. I’m just wondering if this is possibly related to your RME interface itself. I know you mentioned that you do have the latest drivers and firmware, but still - try to change your interface settings just for the test.
Try to use 44.1KHz, but lower the buffer size to 128 samples. This should give you lower latency and possibly drive your CPU even harder, but it will be useful to see if you get the glitch while recording.

Second option … try to create a new GP instance, just for recording. Go to File->Create new instance and type in something like “Recorder” as the new instance.
When the new instance shows up - go to the audio settings and make sure that you use the SAME sample rate, but change the Buffer size to 1024 for example.

Record with this second instance and see how that works. This will off load recording to a second CPU core and will be less intensive because your sample size is large.

Let us know how it goes.


#7

I could verify that the recording issue is related to the length of the buffer. I did tests at 44.1kHz as you suggested. Under 256 samples I start to have glitches when playing, even without recording. From 1024 samples, the glitches doesn’t happen anymore even when recording. But, of course the latency becomes unacceptable.

I still have tests to do, but I already discovered something unbelievable :

when Gig Performer looses the focus, after approximatively 2-3 sec, the glitches stop and the recording becomes OK. If I stop and start the recording again, the glitches occur again. The “cure” is the same and it is reproductible!

As I also made the tests you suggested with a second instance of GP for recording, and even if it didn’t solve the problem, I wanted to do it again to check if both GP instances have to loose the focus to stop the glitches. But I will have to delay this test, because I am unable to start the second instance again. Indeed, for the moment, the second GP instance crashes, probably because the two instances have different audio settings as I changed the audio settings while working with a single instance of GP. By the way, I couldn’t have two different buffer size in the two different instance. Only one size option was available within the GP audio settings. And when I change the buffer size in the RME dialog, it is the same for every GP instance.

Well do you have Dr House in the GP team ? If yes it is time to call him :grimacing:


#8

It is obvious that your setup is a bit too much for your computer. I am not sure if it is related to some settings in your plugins (many have options for live vs. mixing setting or other kind of optimizations… Kontakt has use of multicores etc…) or if it is something else on your system, but it is clear you are running with no “CPU headroom” and many things can put you over the top when you play and produce pops, clicks and glitches.

I could take a quick look at your gig file or if you have just a single rackspace that exhibits the problem and see if there is something else that’s going on.

One more thing … make sure you are not running connecting your audio interface via a low quality or low speed USB hub. That could seriously degrade the bandwidth.


#9

I agree more with your first analysis than with the second one. Here is a screenshot of some performance tools while recording:

My CPU doesn’t seem to be very busy, and however DPC latecy shows what I can hear :tired_face:

Indeed, it doesn’t seem to be related to a specific plugin. I have the same result with Ivory American Concert D, JBridge+MrTramp2, and Dexed. I spent much much time trying different configurations and different frequencies/buffer size, with more or less success, but when recording 4 tracks simultaneaously, I still have glitches. I thought I caught something when I noticed that, when loadind a Gig file with JBridged plugins, even when the corresponding rackspace is not active, an auxhost.exe is started. So I removed the JBridged plugins, but It was not that.

If you think it makes sense, why not, but my last Gig file have only on single rackspace with one single variation and one single plugin. Nothing special…

It have of course a direct USB3 link and I use the original RME USB cable.

I followed carefully the Ableton guys advices, I even trie to replace the RME ASIO driver by the ASIO4ALL one (it was not better), but I didn’t found anything. I can start to stop randomly some drivers, but I feel a little bit like playing the sorcerer’s apprentice :thinking:


#10

That DPC Latency checker tool looks great and it seems to have found something as it is reporting that some device drivers definitely behave badly on your computer and “will probably cause a dropout”

Which is what I think you are seeing.

Not sure which device driver it could really be. Try hooking up an external disk drive and recording to it instead of your internal SSD. Just to see if it makes a difference. It could also be just a USB stick or something like that.

Other than that - it looks like you’ll have to try to check all your drivers, disable devices and look at services etc…

Let us know what you find.