ASIO4ALLv2 doesn't start

Kind GP Community,

lately we’ve encountered an issue with ASIO4ALL v2.14 on GP3.7.0

On selecting an ASIO driver, the ASIO4ALL driver fails to load, prompting:

Error trying to apply settings!
Device didn’t start correctly.

We’ve found this on different machines to be the case. Other regular ASIO drivers do work, (but are’t always available on location).
Uninstalling, restarting, re-installing and restarting the PC doesn’t work.
I tried an older version of ASIO4all v2.13, to no avail.
I thought maybe ASIO4ALL pointing to a driver not available (not connected) was the issue, so i opened ASIO4ALL in reaper with no issues, and closed ALL drivers apart from the windows one. Also to no avail.

It is strange as i distinctly recall having great results with ASIO4ALL, which is the reason we got to rely on it on location, so i am inclined to think either a Windows update or the 3.7.0 update have started this issue. I am open to any solution of course.

Does anybody have encountered this problem, or does anybody have an idea what to do?

Kind regards,
Gerk

Just tested Asio4all v2.14 on 1desktop PC + win10 1909 updated, 1 laptop + win 1909 updated, 1 laptop + win 2004 updated.
It works fine.

Hmm the PC i have here is running version 1903, build 18362.900

I can’t check the version of the other machines as i they aren’t physically with me at the moment, i will check them later today. but so far we have encountered this on 3 machines. I wonder what could have caused it, as my home PC is distinctively different then the one we use on the road to perform with, but they both have the same issue. The only thing all 3 have in common is that we use TriplPlay with them, but that’s unlinkely causing ASIO issue. It works as normal when i use my dedicated ASIO.

The other PC we have that DOESN’T work is also running windows 10 (pro) , v1903 build18362.900, which is a different v then 1909 mentioned above However, the one we have that still DOES work, has a setup identical but is ALSO running version 1903, 18362.900
Only difference in setup is that we also used that to record with CUBASE.

So I will try uninstalling and re-installing GigPerformer 3.7.0 then.
Will i have to unregister and re-register. or can i just uninstall and reinstall? Any advice? I will also look elsewhere on the forum.

Literally the very minute i wanted to reinstall, 3.7.1 dropped! Talk about timing!
Did not fix the issue however… What can this be?

Okay I found the issue. I am updating this tread for the few people who run into this exact problem.
The ASIO4ALL driver is connecting ALL sound devices on my PC. That includes all the bluetooth devices, headphones, small speakers, what have you, i ever used to, i don’t know, watch a movie that one time in bed with bluetooth headphones on. Those things aren’t actually turned on, and for some reason GP has an issue with that (my DAW doesn’t). Being the thorough software it is, i cannot say i am surprised.

I uninstalled ALL (bluetooth) audio-devices i don’t actually need. I left all the USB ones intact, they DON’T seem to be interfering.

That solved it. Case closed. Have a good one!

1 Like

Ouch, but that was some good searching&checking. Thanks for the heads-up! Good to know where to look further, if I run out of ideas.