Amplitude 5 widget control

I’m just starting out on Gig Performer 3.8.1 that I just bought a few days ago from Plugin Alliance unlocked version. I read I could save on performance by using widgets to bypass effects in Amplitude using the same setup by creating variations for verse, chorus etc.

I have tried building widgets with a toggle switch and I am experimenting with many of my different guitar plugins. I tried a Kuassa gate pedal and the widget successfully controls bypassing this pedal. I tried bypassing a Lancaster ODR-1 pedal and on setup the pedal bypass controls the widget switch but the switch will not control the power. It’s like some things control and others do not…the same switch will control the drive or level but not the power bottom (bypass).

The one I am really trying to control is Amplitude. I have tried to use the learn button as well as preassigning the pedal bypass within the software to parameter 1 but I can’t seem to control the widget or the widget control Amplitude. I did get lucky a couple times and Amplitude would turn the widget to off but would not turn it back to on.

Since I am new to this - am I missing a setting somewhere or are there just certain plugins that certain parameters are hard to get the widges to control?

OK so after playing with this all evening I think I know what’s going on. Amplitude is looking for a message similar to a midi message so a switch doesn’t work for bypass but using a rotary knob does activate the bypass like 0-50 is effect bypassed and 51-100 is effect on.

A button should work as well. But if you’re wanting to do bypass, you should use the GP plugin bypass instead.

Hi @matt_butler2001 welcome!

My tests with stomp pedals in amplitube work ok. If you right-click the switch/button in amplitube and ‘Assign Automation’, and then map that same parameter number to a GP widget, it will work.

amplitube param automation

BTW I also used the ‘Invert value’ option in the widget settings, to align the widget LED with the amplitube LED.

I can’t use a general bypass because I am still using the amps within Amplitude…I’m just trying to bypass a delay within the software. Actually there are 2 delays and I want one to mute and another to unmute when I change the variation.

The buttons aren’t having any affect on bypassing the effect other than the rotary dials as I mentioned. Now I have ran into the problem of when you switch the variation nothing happens - it’s like the rotary dials actually have to be physically turned past that mid point to get their bypass state to change.

Just curious if I have some kind of bug in my Amplitude because I can’t get it to work and I have had issues with my iRig stomp I/o erasing the pedal assignments which I tried to resolve with their support but they never got back to me after several months.

This is what I have set up:

Volume pedal>Fender Comp>Echoman (stereo split)>another Echoman into vintage b amp and Vibroverb amp to rack with digital delay>two halls set to different settings which also needed swapped with a variation change

Worship music is complicated and I thought Gig Performer would make life easier once I learn it better

Are you on Windows or Mac? What plugin type are you using (VST3?). If you have a different plugin type, have you tried that to see if it behaves differently?

I am using VST3 on Mac (Mojave) and have noticed no problems when using the ‘Assign Automation’ in amplitube (either buttons or knobs).

BTW, lots of great improvements in GP4 for guitarists. The global rackspace is particularly helpful. Well worth the upgrade!

1 Like

Mac Big Sur VST 2…I can try AU and see what happens. The upgrade would be cool but not in the budget for a while…plus I wanted to figure it out more before I go all in with

It will - but if a plugin is not properly implemented, then one has to use more sophisticated GP functionality to deal with it.

Unfortunately, I’m not personally familiar with Ampltube so I have no idea how its host automation actually works. Some plugin companies don’t always get it right.

However, we have already run into issues with another IK Multimedia plugin that is not properly implemented so we can’t be certain what’s going on in your situation without more details.

But it sounds like host automation is not configured properly in that plugin.

1 Like

Confirmed there is something wrong with the parameter automation in the VST2. Unfortunately these sorts of differences with the plugin versions are somewhat common.

Try another plugin type. I had been testing with VST3 and everything had been working as expected.


Thanks to you both…up to this point I have always used standalone or aax in pro tools so I will do some experiments with vst3 and au and see how that goes. I appreciate you letting me know there are issues. With the customer support I have received from IK Multimedia I guess it doesn’t surprise me!

Yep - you guys nailed it - I just tried AU and it worked like a charm! Many thanks to you both!


Hmm, have you tried VST3? If this is only failing with VST2, it would be helpful to report the issue to IK.