Adding a KRONOS & KORG NanoPAD2


#1

Currently, the only MIDI controller I’m using is my Nord Electro 5D. I need to incorporate my Kronos and the nanoPAD2 connected to it as an additional MIDI controller and set up the nanoPAD to turn the Audio File Player, as well as setting up two slides on the KRONOS to control levels on two gain control plugins post file player. I’m fumbling with how to accomplish this.
Thx
Mark


#2

To clarify - the nanoPAD2 is to be set up to turn the audio file player on/off


#3

You could do a mapping of Play/Stop in the global midi preferences to start/stop the global play.
In the audio player you check the sync option and you are ready to go.

For the mapping of the gain controls:
Include 2 widgets you like and map it to the gain controls.
Then do a midi learn of the 2 widgets.


#4

Not sure I comprehend. In Edit mode, MIDI is not assigned yet. I’m clicking on the widget I created to stop/start the audio file. Any controller I press or move on the Kronos isn’t registering. Very confused.


#5

Did you select the Widget in edit mode and then clicked on the “LEARN” button in the midi settings before pressing your MIDI controller?


#6

The Kronos is not sending any MIDI information. I’ve swapped out USB/MIDI cables and have been searching the MIDI menu in the Kronos to know avail. I sent a message in the Kronos forum, so hopefully I can get steered in the right direction. I’ll keep you posted.
Thx


#7

Definitely some wrong there. I’ve had a Kronos for years and they most definitely send MIDI data out. However, be careful…depending on how you have it configured, it is absolutely possible for the sliders on the left to send real-time sysex messages rather than MIDI cc events.


#8

You really should use some kind of MIDI monitor to see what is coming out of your hardware.


#9

I have. Hence the issue I’m struggling with.


#10

Well, what do you see in the MIDI monitor??? (We can’t see your MIDI monitor!) Are notes going through it? Is it just CC messages that aren’t apparently going through?


#11

It’s the app David suggested I download, plus I’ve also used the plugin that comes. Nothing is coming through.


#12

Oh, you’re talking about the snoize MIDI monitor on the computer. If you’re not even seeing MIDI note events, then there’s something seriously wrong somewhere - it’s not a Gig Performer issue though. Are you using MIDI cables or a USB connector?


#13

I’m using USB


#14

Are you connecting the Kronos directly to the Mac or are you using a hub?
If you run the Snoize MIDI Monitor and plug the Kronos in, then press Rescan menu item of MIDI Monitor, you should be able to see the Kronos in the list. If you can’t, then (unfortunately), you’ve got a hardware issue somewhere. As far as I remember, there’s nothing to configure on the Kronos to enable USB, it should just work.

screenshot_260