Ableton link doesn't work

I’m new to GP and also started working with Ableton (since I need the tempo to sync and when I use GP with Cubase I get really bad noises when I’m playing guitar) and I can’t connect the link option… I have Ableton Live 10 and the link worked for the first time, but after closing and opening both software- it stopped…
Anyone knows what might be the problem?

I am using Link with Ableton Live 10.1.18 and GP 3.8.0 on Mac and it is always working.
How does your environment look like?

quite regular… just open Ableton and GP and press the link button… I might miss something but it did work before

OK, and what does not work?

The “1” is missing from both the Live and GP buttons to indicate they have connected.

And when ‘1’ is missing, it does not work?

Nope, first time it worked there was a ‘1’ in the link button, and the tempo change responded in GP when I changed it in Ableton. Now… nothing

Now when you restart GP and Ableton Live and you acticte LINK in GP and Ableton Live => it does not work?

Is Ableton running on the same computer or a different computer?

It doesn’t help if I restart it.
It works on the same computer, yes

The only reason I can think of this not working is your security software/firewall preventing network access to either application.

This might actually be the case… First time clicking on the “Link” I accidently pressed on cancel instead of allow. Only after going into the settings and allowing GP to continue, it worked, but only this one time… I think there might be a different setting in windows I’m missing, but I have no idea where to look

Yes - this would definitely do it. You’re blocking network access which Link uses to communicate.

As mentioned, I got into the settings of the firewall and enabled all access. Even after resetting the firewall and enable bot GP and Ableton, the link is still not responding…

Security applications on Windows are notorious about resetting and setting state for applications. You must have missed something. Typically the best way is to reset or remove every entry about a certain application while the application is Not running.
Then start the application again and you should get promoted to allow access. If it doesn’t prompt you - it means you didn’t remove everything…

No idea what I’m missing… I am now uninstalling everything using software to remove all trace and I’ll try it again… If it won’t work I’ll contact the support

You’re getting responses from the developers via this forum :wink:

1 Like

I tried installing it all over again and removed any trace. Upon reinstallation, it still doesn’t work… I might do something wrong since I’m new to Ableton… Any ideas what could go wrong?

OK! found the problem… I found out that link is working on a network connection (doesn’t make sense when both software are on the same PC but what the hell…) and it’s not working with VPN turned on…


You actually can use Link on the same computer using “localhost” but yeah, VPN connections can screw up a lot of things. Thanks so much for reporting back what happened, it will help others in the future should they encounter a similar issue.