Inexplicable audio dropouts/popping sounds only in Gig Performer 4

He said he used ASIO and got no dropouts so I guess he’s not in demo mode.

@nodrog When you say you played your guitar with no plugins, can you show us a screenshot of the wiring connections? Also, what sample rate and buffer size are you using?

Given that there are numerous GP customers playing guitar, it’s pretty clear that there’s something else going on that is causing this problem.

From what you describe, this issue only seems to happen with the Focusrite driver, is that the case?

1 Like

is gig performer the only running audio software at that time?


Thanks for the welcome, Paul! I really appreciate all of your prompt responses.

@dhj, the wiring was just straight from the audio interface guitar in, into its stereo outs (monitored by headphones). I tried 44100, as well as 48000 sample rate, trying many different buffer sizes with each. It does seem to be the case that it is only happening with the Focusrite driver, although I didn’t experiment enough with Asio4all to know for sure there were no dropouts.

After reading your question about other devices running audio software @pianopaul, it gave me the idea to try disabling the Focusrite speakers as a windows playback device. There are also the settings “Allow applications to take exclusive control of this device,” and “Give exclusive mode applications priority,” which I thought I had disabled earlier, but they were checked so I disabled them again. I just tried playing both my midi keyboard and guitar again in GP4 (48000 and 192 buffer), and did not notice any dropouts! So either that has greatly reduced them, or eliminated them! I wish I had posted to this forum sooner! Any idea what is going on here? Are there any other steps I should take to prevent this from happening?

1 Like

you should use a multiclient Asio driver

Do you have a suggestion of particular software? Do I need this for GP4 to work well standalone, or just if I want to use my audio interface in multiple applications?

Yes a multi client Asio driver allows to use different audio software to use the same audio interface.
I am on Mac, therefore such issues do not exist at all.

did you download the newest driver from here?

  • Fixed an issue that could cause glitching when using more than one ASIO application at the same time

Ah okay, yes it seems like there are very limited options on Windows if it is not built in to your device. For now I have no need to use multiple applications with my interface, just having GP4 working is all I need! I will try to route between GP4 and VCVRack, as well as Reaper for recording, but I am not sure if I will need a multi-client driver for that. I just got the interface last month, so I should have the latest driver. I just re-installed it though, just to be sure. Thanks!

And in gig performer you have to choose the correct one in the audio options.
how do the audio options window look like?
can you upload a screenshot?

1 Like

Hi nodrog,

That is exactly what we noted in the Troubleshooting section of our free guide for optimizing Windows for audio. This guide is also available online :slight_smile:
Link: Exclusive Mode


Yes, I believe I have that configured correctly. Here is a screenshot just in case.

Ah, I thought it was familiar! Somehow it reverted or I did not save it somehow. I went as far as to disable the device from that control panel entirely. It seems to be much more stable now, thankfully.

1 Like

Yes, some of the settings Microsoft may revert after Windows updates or Feature updates. So you need to re-optimize your PC again.

Fortunately, we published a free guide that may help Windows users to have a stable and glitch-free platform for real-time audio. Check it out and feel free to share it :beers:

1 Like

This is the same interface and sample rate/buffer that I’ve been using with Gig Performer for the last few years, with no problems (also a guitar player).

I’m on MacOS so I know it’s not a comparable situation to Windows when it comes to drivers. But I hope you get to a stable position with your setup.

And welcome to GP!

1 Like

Ah okay, well that’s unfortunate.

Yes, thank you so much for providing that resource. I’ve found it very helpful. I’m not sure how many others have had the same issue as me, but it might be helpful to include some info about the symptoms, and the fact that the settings may revert.

1 Like

That is great to hear!! Yes so far so good, I will come back with questions if any issues come up. It sounds like I should get a mac next time though!

Thank you, appreciate the warm welcome.

Another approach is to use Virtual Cable (VB-Audio Virtual Apps)

1 Like

Ah thank you yes! I have heard about this. The focusrite interface also has a “loopback” function that enables inputs from cpu audio, I will also explore that as an option when I get to that point in setting things up.

This is always a good idea as allowing Windows to use your audio device for system sounds at the same time you’re playing is really NEVER a good idea for many reasons, including device overloading which you most likely experienced because Windows used your audio interface.


Can you confirm that this fixed the problem?

1 Like

Yes, working perfectly now, thank you!