Widget assignment issue

Hey All,

So I use the Rig Manager and assign aliases to my various keyboards. They are assigned as “Upper Keyboard” and “Lower Keyboard” among my 3 rigs. All 3 rigs have different controllers.

When I recently assigned the lowest note on my Lower Keyboard to trigger playback of a file in the original (RAM based) Audio File Player, it does not translate to my other rigs. It is looking for the specific keyboard (in this case, an M-Audio Keystation 88 on my workstation rig, rather than whatever is aliased to “Lower Keyboard.”

When I look to edit the MIDI In assignment under the Widget Properties…there is no option for “Lower Keyboard” as it is aliased in the Rig Manager…only the specific MIDI IN devices are listed.

Is there any other way around this? Or should I instead load that audio file into Kontakt and trigger it using a MIDI IN Block directly to the plugin?


You probably have to define a TRIGGER_NOTE control alias name, map it to the MIDI note of the MIDI controller you want and use it for your trigger playback widget button.

Is it what you have done ?

Could we see the MIDI tab of your playback widget button? And also the MIDI control alias name mapped to the chosen trigger note?

Here is one possibility (I only make “low tech” guesses).

Could the midi notes on they keyboards be different based transposition, etc.? Maybe see what happens if you hit a few octaves higher and lower (?).

Here is what it looks like. You will see in the first pic (the Rig Manager) that the alias “Lower” points to a Hammer 88. On the workstation PC I created the song on, the Lower points to a Keystation 88es. It’s not associating the two controllers from different rigs, and so the keyed trigger is not working. You can also see from the “edit” pop-up to the right, that no controllers or aliases are an option to choose from.

You can see the widget “PLAY” boxed near the pop-out.


YOU have to define a MIDI Control Alias name on the column of the right of the Rig Manager. Let’s name this MIDI Control Alias TRIGGER_NOTE, double click on it and play the note you want to define as a trigger note. Then map it to the PLAY button.

1 Like

Ahh…yep…that works!

Thanks @David-san

1 Like