Unable to route audio from inputs to Amplitube 5

Set the corresponding input fader to 0 and it won’t anymore, while your audio input will still be available fro GP (with full level as the TM fader will not act on it within GP).

Don’t forget that GP “sees” the analog inputs pre fader, while the GP audio outputs are the TotalMix software playbacks.

@Fritz you only have an audio routing issue. TotalMix Fx is very close to a professional digital mixing console, which in the hands of a musician makes it look more like the cockpit of a fighter. :wink:

Start trying this:
1 - set the hardware inputs intr.3/4 fader to 0
2 - keep going using the SUBMIX option but add also the TRIM option (in the badly named “View options”) => I suppose you want to monitor the same whatever if you are using phone1 or main monitors)
3 - set a direct wiring au GP Audio in 3-4 (RME hardware inputs intr.3/4) to GP Audio out 1-2 (RME Software Playback AN1/2)
4 - double clic on the GP Audio in block to display the mixer plugin window which will display meters for you to check that you get audio in GP
5 - do the same with the GP Audio out block to check the meters from tere too.
6 - now you should have the meters displaying your audio signal at Software Playback AN 1/2 in TotalMix.
7 - if not post a screenshot of you TotalMix Matrix View


…which is why we went with a visual routing approach in Gig Performer rather than using channel strips!


Thank you David. I’ll get a chance to sit down with this this evening. I’ll try this and report back with my progress.

Thanks David. I’ll try this this evening. When you say fader to 0, do you mean set it to zero db or pull it all the way down? Mixing nomenclature is not always clear to me.

I think that was a brilliant choice, going the visual routing approach. Not everyone is a mixing engineer.

Yes do this, not 0dB

I did that and still got no audio. The in/out mixer plugins show the faders but no level meters or indication of signal. I’ll attach a screen shot of matrix view and the GP screen including the audio set up window.
Screen Shot 2022-07-06 at 10.15.17 PM

With this matrix, without any routing in GP, you shouldn’t be able to monitor your instrument in inst.3/4 in your phone1, but when int.3/4 is routed to AN 1/2 like you did in GP it should work. The only think I cannot check from you screenshot is: did the meters 3/4 in Audio in and 1/2 in Audio out display some activity when you play your instrument? If not, change your instrument cable or the batteries of your wireless transmitter. :grimacing: Seriously what do you observe in the Audio in/out meters when playing? (And please close the audio option settings, that’s OK and I don’t remember if the audio engine is active when this dialog is open. Rather put a Totalmix screenshot here).

I don’t see it on your screenshot (but trying many things at the same time it could happen), but please also check that no MUTE, SOLO, CUE or LOOPBACK is active.

Its not active so please close the option dilog.

1 Like

There was no signal showing on the level meters in either input or output mixer plugins in GP. And as far as I can tell, none of the mute, solo cue or loopback are engaged. Audio is not arriving in GP. I just included the options audio i/o dialog to show that the babyface is recognized and selected as the interface.

This is beyond comprehension.
Could you please make me a single screenshot with Totalmix, your GP wiring and the Audio in/out windows on the same screen? And this, while you are playing something on your instrument. Such that I can see what activates or not. Unbelievable…

There was an earlier comment that the audio engine is not active when the audio in/out dialog is open. I’ll make a screen shot of the rest though. The audio in/out is the same as the earlier screen shot. It’s set to Babyface with all inputs and outputs showing as available.

I’m tempted to go back to basics and make sure I have the correct driver and firmware installed and do some reading in the manuals. I looked at possible sources of the problem in Amplitube’s manual and came across their advice to make sure software monitoring is selected. I know how to do that in Logic but can’t find a way of making sure of this in GP. Also, there has been a known issue with the security updates in Mac OS 10.14 Mojave, where a permission to access microphone (could never understand this one) must be set before audio will work in total mix. The thing is audio does work in total mix. I use it all the time. I just can’t get it into GP. This weekend I’ll have a block of time to dig into the manuals and maybe some tutorials to see if I’ve missed something there. Thanks for all your patience and willingness to help. I appreciate it. In the mean time, if you have any other suggestions, or if there is a TotalMix FX power user that has the app mastered around, I’d love to get their take on this situation. It really doesn’t make much sense to me. My guitar playing partner plugged his Axe I/O into his Mac mini and it was instant sound and easy routing. So again, it’s pointing to TotalMix on my laptop. I have other interfaces I can try to see if it’s the interface or a setting on my computer. This weekend I will give debugging this my best shot. Also, this won’t affect my enjoyment because most of my work will be midi rather than audio. But I’d like the audio working so I can integrate audio and midi and for any other visiting guitar players I need to give some amplification with a variety of tones to.

Oh God, I think I’ve got it. I am not a Mac user, but you have to allow the Mic input for Gig Performer somewhere in the Mac settings! :nerd_face:


I was just mentioning that in my last comment. I went to security and privacy and the option to select it is not available. I’ve had it come up before and a dialog opens that takes you to the page where the permission can be granted. It will come up automatically if I reinstall the drivers for the babyface.

I just noticed it, it seems we posted simulateously. It is Gig Performer who needs to have the permission for Microphone use.

Yes, it’s a poor message but Apple doesn’t let you say you need permission for “Audio input” so it’s a bit confusing if you aren’t in fact trying to use a microphone.

That was it! GP and TotalMix FX both needed permissions. First attempt at routing audio into GP and voila, success. Thanks David and everyone else who tried to help.


I’m surprised that TotalMix still needed this permission because your screenshots showed that TotalMix meters had activity on the inst.3/4 input… :thinking: