? two GP3 instances with blackhole, connection is NOT working ? (edit: Noworky on M1 mac)

Edit:
ok, seems to be an “issue” with the fact that i sit on a new M1 macmini.
and also is it looking that the new mac is something different on the aspect how easy it is for external apps like “blackhole” or “loopback” to get access to their audio access points, under the hood.

Loopback (rogue amoeba) has a Beta out,
but the installation of the underlaying ACE app requires some “juggling and adjustments” in the security dialog of the system settings.

so, there´s a change here with the M1 macs it seems


i just tryed to work with two instances but i failed. ( macOS Big sur )

i use Blackhole 16CH.
The signal would go out at the first Gp3 instance, but not coming in in the next GP3.
the audio settings are accordingly in both GPs instances.

i created a aggregate file,
but it seems to me the failore is there.
(on audio midi setup) it shows in the left: 0 inputs, 2 outputs.
also if a try to adjust Blackhole allone ( non aggregate) i allways just get a master fader that i can set to on. the other faders are greyed out/inacessible.

what can i try ? macOS big sur ( a totally fresh installation, in fact a new mac (mini) )
Blackhole was rated as Big sur compatible

Please post screenshots of Audio Settings in both instances and your routings in the connections views

1 Like

what ecactly do you mean by connections view ?

it might take some time…tonight or tomorrow

It is called back view

1 Like

haha, ok, two screenshots, each with both instances in the picture,
left the instrument, right where it has to go, the FX one.
see, i played a chord, the level meters show activity on the Instrument one.

the second picture with both Audio settings dialog open,
i´ll add afterwards a screenshot(s) from the Audio Aggregate etc. settings

(Edit2: on a side note: i just tryed to run both GP instances side by side, each with the full original patch going, so with no need for a audio interconnection.
This is doing fine ! …ahh, ofcourse with readjusted audio Out settings)

Edit: the aggregate Device.
look how it says_ 0 inputs, 2 outputs ( guess you speak german too :wink: )

The blackhole alone ( not as aggregate)
look how i can´t enable the chanel faders !

Don’t worry about the channel faders in the Audio MIDI Setup. It’s like that for me but doesn’t cause any issues.

What does the text say in your screenshot of the Aggregate Device? This is what mine looks like:

1 Like

within the in blue highlighted Aggregate window on the left,
is it saying: 0 inputs, 2 outputs

on the right do i miss the whole middle section, that you have.
now i understand a bit better, that was shown on the Blackhole page and the instructions how to set this up.
…its not there that window (big sur, M1 mac),
but its also not there on my old mac with high sierra

You might have created a ‘Multi-Output Device’ instead of an ‘Aggregate Device’.
Try creating it again.

image

1 Like

indeed, thats what i have donne !

i have only two options, but its in german language, its not similar:
one says: create a main device ( Hauptgerät)
and one says: create a multi output device

so i must guess that “main device” is here the term for the “aggregate device”.
i´ll try …:wink:

ok, there i get now the whole setup dialog !..that must be it !

it will take a moment to setup the GP3 instances…

1 Like

ok, i reworked everything, since my patch had evolved,
i created a new (real) aggregate device, but it is all still not working.

the state is the same as bevore:
GP3 instance 1 shows on the level meter a outgoing signal,
but instance two shows NO incoming audio.
( i checked the signal flow within the FX-rackspace of the second GP instance by adding a instrument to be shure that the audio would come out.
Instance two is working correctly when adding a own instrument in there )
the problem is really that no audio is sent to the blackhole inputs ( on instance two, the FX-unit GP)

i add another screenshot showing all three:
the in-out routing on the rackspace of both GP instances, as well as my aggregate window/setup.
The audio setup within the GP Audio setup dialog is correct

ok, i found the wiki manual and this tip there:
(but it did not help in my situation )

IMPORTANT: Due to issues with macOS the Built-in Output must be enabled and listed as the top device in the Aggregate<<

In Audio MIDI Setup, select the Blackhole 16ch and double check you didn’t move the Master slider to 0 or click Mute.
Otherwise, it looks like it should work.

1 Like

i understand what you mean,
i just checked: its all setup fine.

my interconnection thru blackhole is still NOT working.

now, i sit on a new M1 mac,
so it could be this. but i read that blackhole is good for “big sur”

I need to test tomorrow the whole thing on my old macmini…

thank you both very very much for the help so far ! Much appreciated

There is a difference between being ready for “big sur” and being ready for Big Sur on the M1 which has a completely different processor.

Looking at their git repository, I see nothing about M1 support, just Big Sur on Intel machines.

yes, it seems that this is it !
also was i so far not exactly aware of this little difference.

what i can say now is:
i just tested a dual instance patch on my old macmini, and this worked now with using blackhole.
It seems that i´ve donne there the same failure in the past: to NOT create a aggregate device but a “combined device”.
So at least, this weak point in the equation is now out of the play, hehe :wink:

also, was i checking Rogues Amoebas “Loopback” which i have on my old macmini.
means, its payed, i can install it on my new M1macmini, which i wanted to do, BUT:
there is a small detail: Loopback uses a underhood app called ACE, and:
the M1 mac is NOT allowing the installation of Ace by default.
Rogue Amoeba is giving install instructions, …but i´m not shure if i want to do that on my new mac…
my guess is that this never will change, since the M1 and the OS won´t change here.
and also my further guess: That blackhole is also prevented to work based on the same security routines, and that it also had to “change” something under the hood…to make it working.

i need now to find out how much or how NOT its adviced to do these under the hood tasks to install ACE,
and how good thats reversible or not.
i have no clue on this things.
otherwise could i try Loopback, they have a Beta for the M1 mac

Thanks anyway to everybody for the Hand !
it has shurely helped to sort out a shortcoming of my handling with aggregate devices,