Sustain pedal and reason 11 latch issues

We have just tried this on a Windows machine with 3.81 and the sustain pedal seems to work just fine.

There has to be something else going on there. This is very strange.

So the MIDI messages are not altered in front of the Reason VST3, but it doesn’t work well.

This is really strange. Do you have the same issue when using the VST2 rather than the VST3 plugin ?

The Reason plugin only comes in VST3 version for Windows

Well I am not sure but I also loaded and tried the up to date version of reason before posting. Just in case
it was reason related. ( computer is off ). Although the problem remained the same.
So it is the most recent by a day, from this posting date.

Just for your info, it is windows 10 pro up to date, Ryzen 3750H series , using a komplete audio 6 ( mkII ) USB interface with most recent drivers.
I have no issues with reason 11 when used stand alone.

@djogon did you experiment the same “latching sustain” issue?

No, it worked fine for him…as it did for me on Mac. That is why we are puzzled as to what is going on

@neovich: Why don’t you just upload your rackspace or gig file, so people can have a closer look at it?
I think, this is always the easiest and most promising way to locate such issues.
Help people to help you. :slight_smile:

1 Like

@neovich - we never really got an answer on the EXACT version number of reason you are using - could you please send us the exact version you have?

I guess what you guys don’t understand , which I will explain here, is reason has rack extensions. If you look carefully at my earlier screen shot, i am using a rack extension in this patch.
So it is pointless sending my GP file if you don’t have those rack extensions bought and installed on reason 11. It simply won’t work. I have bought more than 5G worth of REs .
Mind you , I did try a few different instruments native to reason 11, they all did the same thing (in version 3.8.1) , incorrect sustain pedal operation.
Everything else was fine. So unfortunately , it is a real problem and not an imaginary problem in that version.(3.8.1)
As i mentioned , i went back to version 3.8.0 and all was peachy again !

Also , I do have the absolute last reason release version on the pc in question. Please don’t ask me that again.

Here is a suggestion. As all of my reason patches have been saved as combinator patches (instruments inside of combinators) , maybe what you guys should try ( version 3.8.1) is a combination container with an instrument inside it , like the ID8 piano . Then try the sustain pedal in realtime.

That’s not exactly what I asked. This is what I asked:

Of course the simpler possible gigfile which makes it possible to reproduce your issue.

There are no fortune-tellers among us (I think :stuck_out_tongue_winking_eye:), we need information. The principle of getting help here is not to assume that all of the questions asked are useless. The idea would rather be to think that something is missing to all of us. Perhaps you could try to give us the few pieces of information we requested such that we can keep trying to help.

The first step would be to be able to reproduce your issue with 3.8.1. As it sounds like a bug, I think it is important to track it further. :face_with_monocle:


The latest version on your computer and region may not be the latest on someone else’s. The ONLY way to know we use the SAME version is if you actually tell us what the full version is. Numbers and letters included.

As @David-san already said - we need information. We’d like to help, but the first step is to reproduce the problem. Can you reproduce the problem by inserting Reason plugin into GP and selecting just say the “Europa” synth?

Here is a dead simple gig file with no widgets, other plugins or anything extra.
If you open it and try your stain pedal - does it work?

Reason-Europa.gig (53.5 KB)

Sounds like i am helping you guys with the problem now… lol
Well thanks for your help, cheers guys.
As mentioned ( using 3.8.0 ), it works as one would expect. Good luck in finding issue.

The principle of a community is that everybody helps everybody else. I personnaly don’t use the Reason 11 VST, and it seems you are the only one who has a problem with it and GP 3.8.1 for now. But, it could potentially affect other users.

Hummm, does it mean you don’t feel to be part of the GP community? :roll_eyes:

FWIW: I just downloaded the trial version of Reason. Everything is working fine. I have sustain in every plugin I tried. In @djogon Reason-Europa.gig the initial sound that was loaded at first sounded like it wouldn’t sustain. But that was just the nature of this sound. There are background activities going on that would sustain. I switched to several other sounds and all sustained well.

1 Like

Right now, nobody else has the issue — everyone who has tested it has found it to be working properly.

It is fine if you don’t wish to help tracking down the issue but the downside is that, as we release newer versions of Gig Performer with more functionality, you won’t be able to benefit from new functionality if the problem you experienced is still happening to you.


GP Community frontdoor is locked. Knock Knock, Hey let me in you guys …lol
You are right, you guys are not fortune tellers, lol.

Anyways, Just so you understand why you have not got any more info from me is simple really, I am not around the 2 PCs with GP and reason on them. ( it is an hour drive away from me )
and i wont be back until our next rehersal session next week sometime.
Unfortunately, I let a bunch of people down the other day when we needed to use Gig perfomer in our set list .
and it cost me 2 days of lost time. So yeh, i was a little pissed at the time, but thats ok i am fine now that it is working again.
So don’t assume I can give you all the info straight away, so lets be a little more patient,shall we now.
If you noticed, I am trying to suggest ways to replicate the problem so you can try it for yourselves.

So what I am going to try:
the machine i am on right now ( older home machine ) it has windows 7 on it,
I will install reason 11 on it. I just finished installing GP 3.8.1 on it and then I will see what happens.
Just got to find a decent sound card…with midi/usb and find a midi keyboard
I will post if it still has a problem .
Not sure if window 7 will even be relevant , but who knows…

1 Like

We are sorry you had a problem. Ironically, we have an article that specifically addresses this potential risk, and it’s something we all practice ourselves.

We look forward to hearing what you discover and if the problem is still there, we hope to be able to work with you to solve it.

Come in, it is never closed :stuck_out_tongue_winking_eye:

Even if the issue is solved, because it is always interesting to know.

So, welcome to the GP community? :grimacing::wink:

1 Like