SuperLooper and Airturn SB-200 foot controller

Hi- I’ve been using Airturn SB-200 foot controller to control my metronome. I can control the global midi metronome with success by selecting the PlayStop function and hitting the learn button which recognizes my controller when I step on a switch. But now I am trying to control SuperLooper by Melda with the SB-200. I have a widget that will control the Start and Stop button it, but I am running into a wall trying to connect the widget with my Airturn SB-200 foot controller. I’m thinking this is a scripting opportunity but so far my somewhat feeble attempts have been for naught. So… I am throwing my self at the feet of the community and asking for help. I guess the first question should be “Is scripting the way to go?”

Did you already map your controller to another widget or in global midi?

Scripting shouldn’t be necessary at all to do what you want to do. But, could you please detail what you mean by this ?

What happens exactly? Or what do you expect to happen and what does finally happen instead?

I have assigned button #6 (of six buttons) to PlayStop in the Global midi option window but that’s the only one.

OK, lets do a test: Unassing button #6 and try to Midi learn this button for your widget.

I de-assigned the PlayStop function and then attempted get the learn button of the widget to connect to the floor controller but no luck.

Thanks David for the quick reply. I have a button that will activate the Start Recording function in SuperLooper. I assigned that record function in the edit window of the front of the rack. And it works fine. What I want to happen and expect to see is the controller and the widget function assigned to the controller (button #1) but it will not assign.

In the midi section of the widget it says “no midi in assignment yet” but when I press the learn button and then click on button #1 of the SB-200, nothing happens. But again, I was able to assign the SB-200 to the PlayStop function in the Global Midi window under Options so it works there.

What does the Midi Assignments Window show?

Ans what is shown in the Global Midi Window when you press button #1?

The midi assignment window shows this.

But no assignment is shown in the Global options window.

Have a look in the Setlist/Songs section in the Options window. You might have your controller buttons assigned there, which will mean you can’t then map them to a widget.

1 Like

Exactly, we cannot see in the MIDI assignment screenshot, which controller button is already assigned. But it is probably that.

And please take a look at the global midi monitor window if button #1 is sending a MIDI Message.

Success, as far as achieving connection with the widget.

Indeed, I did have the buttons assigned in Setlist/Song section. I cleared them and it worked as I had hoped.
I was also able to see the button respond in the midi monitor window.
Thanks so much for your time because I was floundering. I feel like GP is a big city and I hardly know how to get to the grocery store and back. But I’m getting there. Now let’s see if I can get MSuperLooper to do what I want.
Thanks again,


I’m interested to hear how you go with MSuperLooper. I’ve given up on it as I found too many bugs with it, particularly when trying to sync with the host (there’s similar comments on the Melda forum). But that’s not to say they won’t be fixed in future updates.

Have you tried Enso from Audio Damage? It’s rather interesting. Took me a while to figure it out but it’s very good

I bought it when it was first released. The company never responded to multiple support requests, which definitely soured things with the plugin. The latest update (which took 15 months to happen from version 1.0) seems to have fixed my issues, so I will give it another go.

One thing I never thought happened in the prior version is my MacBook CPU sky rockets with the plugin window open. But it’s better looping practice to not be looking at the UI.

I never used a looper before and would like to try it. Could buy the MSuperLooper at a -60% introductory price (still running for one day).

60% off broken is still broken :smirk:

1 Like

Oh, is it? I think missed something :grimacing:

Give it a test. I’m trying again today with the VST version and have managed to avoid a lot of the bugs I initially came across (playback stuck in a single spot giving high-pitched squeal, overdubs at what sounded like 2x level). So it’s not all doom and gloom. And from a guy who’s been buying heaps of Melda plugins lately!