Second crash with GP 4.15 on macOS

GP 4.15 works stable on my Windows PC, until now I never had an issue.

But today I have troubles, to load my Gig File on my MacBookPro (late 2013, Catalina).

I had the same problem a few days ago, but after a reload it works. I have made no changes only updates.

Today I have reloaded GP up to five times, every time it crashes immediately while loading the first rackspace. Then I load other GigFiles, they all crash.

After a restart of the Mac I load other GigFiles, they all crash. At least I load the normal GigFile and it suddenly works…

I send the report to Apple and I have made a copy of this report for me.

I won’t contact the technical support of PluginAlliance, where I bought GigPerformer.

In a live situation this would make me a little bit nervous. :wink:

What could be the reason?

Apple won’t do anything,
How about letting us see the crash report?

Yes please - if you have the crash report text - please zip it up and attach here or send us a private message with it and we’ll take a look.


My MacBook is in the rehearsal room, I have copied the report and send it as Email to me, I am in home office.

Can I send you the mail as private message or should I zip the mail?

Zip the mail and just post it here please

Okay, done! GigPerformerFehler (28.1 KB)

Thank you @SirTommes - as you can see in your crash report your Pianoteq7 vst3 plugin crashed

Thread 0 Crashed:: HotFudge  Dispatch queue:
0   com.modartt.Pianoteq7. VST3   	0x0000000112a3dc16 0x112a06000 + 228374
1   com.modartt.Pianoteq7. VST3   	0x0000000112db78d7 0x112a06000 + 3872983
2   com.modartt.Pianoteq7. VST3   	0x0000000112ca5c6f 0x112a06000 + 2751599
3   com.modartt.Pianoteq7. VST3   	0x0000000112ca4f95 0x112a06000 + 2748309
4   com.modartt.Pianoteq7. VST3   	0x0000000112cac140 0x112a06000 + 2777408
5   com.modartt.Pianoteq7. VST3   	0x0000000112cac1f8 0x112a06000 + 2777592
6   com.modartt.Pianoteq7. VST3   	0x0000000112a2789e 0x112a06000 + 137374
7   com.modartt.Pianoteq7. VST3   	0x0000000112a25242 0x112a06000 + 127554
8   com.modartt.Pianoteq7. VST3   	0x0000000112a265da 0x112a06000 + 132570

Unfortunately there’s not much we can do here, but make sure you have the latest plugin version and I’m sure that people ad Modartt would appreciate if you sent them this report so they can fix the issue.

1 Like

I send the report to Modartt, and I hope, they could solve the problem.

But I would be surprised, because Pianoteq7 is the first VST in the whole GigFile and the other GigFile have other VST’s and they also crash immediately.

I will report.

Please send that report as well and we’ll take a look.

Sorry, I have copied only one report.

If it crashes again, I will come back to this topic.

There may be something else going on that is driving these crashes but it is very unlikely to be an actual Gig Performer issue. If this stuff was all working before and is now failing, something has changed in your environment.

I just noticed you are coming from a Windows environment. Was your gigfile created on windows and then opened on the Mac? If so, it is possible that some of the plugins represent their states differently on each platform, depending on how they were implemented, and if they’re different versions and that could cause a problem as well.


When I bought GP 3, I used Mainstage on my MacBookPro. On my Windows PC I created a GigFile and after all rackspaces were ready and worked, I transfered them to my MacBook. On Windows I had some rare crashes, but I didn’t care, because I use Windows only at home, not for rehearsal and not live. GigPerformer 3 on macOS was wonderful, no crashes, no glitches, it worked perfect for me, much better than Mainstage.

GigPerformer 4 on Windows is rock solid, no crashes, it works, same on macOs, awesome.

GigPerformer 4.15 hasn’t changed the performance on my Windows PC, but on macOs, as you can read in the first post. I use my MacBook only for music and only in the rehearsal room, I haven’t changed the rackspaces or the VST’s, except the AdamMonroe Rotary Organ 2.52, but it is in the last rackspace (No. 33).

Between GigPerformer 4 and 4.15 were two updates on macOS: a Catalina Security update and a loopback update.

Modartt asked me to attach a Gig Performer project that uses only Pianoteq and that triggers the crash.

I will try and report…

Are you saying that if you revert back to GP 4, you don’t get any crashes?

I could be, I don’t know.

GP 4 on my MacBook had no issues, suddenly after the update it crashes. But it could also be the Catalina update or the loopback update.

I will bet that GP4 will behave exactly the same (i.e, crashing) with that gig file.

Have you tried running GP4 with an empty gig file and then manually drag plugins into it, etc?

I will try that, especially because Modartt asked me to attach a Gig Performer project that uses only Pianoteq and that triggers the crash.

I have to drive to our rehearsal room, where I have my MacBook. But tomorrow morning they warn of a storm here in Germany, may be it is better to stay in home office tomorrow…

It’s not really a storm only windy…

I have tried to run GP4 with an empty gig file and then manually drag plugins into it, for example Pianoteq7 VST3, it works.

In my big GigFile I have replaced the Pianoteq7 VST3 with Pianoteq7 VST, no problems, it works.

So there is no new crash-report at the moment.