Scripts don´t work after jumping to a rackspace


#21

To determine whether callabacks are working, you need to put that statement in all your rackspaces, not just one of them


#22

I just switched to #1 and turned the volume to check if it works there. Then I switched back to #19.
I controlling it from an external encoder via MIDI and a widget.


#23

NO MIDI data and AUDIO when Bypassed in this way (saving CPU)
maybe is just that ?


#24

And are you going to tell us whether it worked or not when you did that?


#25

Also, if you create a new gigfile that has only rackspace 1 and 19 in it, can you still reproduce the problem?


#26

@dhj

1.Now I added the print to all rackspaces and all 3 parameters.
One interessting thing I can see in the log is, that when I switch the racspace I instantly get a few messages saying “called with 2”. I don´t know where these are coming from as I only use parameter number 0.

  1. I did what you said and exported -> imported #1 and #19 into a new gigfile. The problem seems not to be present then. I toggled between them quiet a few times.

  2. This test made me think to switch off “predictive loading” in my big gigfile. And voila… now it works. I can switch to an yrackspace in random order and all bypasses can still be controlled from the script.
    So somehow the predictive loading seems to create some issue.

I used predictive loading with 5 rackspaces. Without it 15GB of my 16GB RAM are used, so I would prefer to switch it on again.

Maybe predictive loading was off when @djogon tried it.


#27

…which is why the callback tests for 0 as other parameter changes (such as the magnitude, which is parameter 2) can generate callbacks

ok — that’s far more likely to be the issue rather than a scripting engine crash. Good find.