Scripts don´t work after jumping to a rackspace


#1

Hi guys,

maybe some of you could help me out here. I added a little script in order to bypass some plugins when volume is down (as GP wrote in their blog article).
In general the script works well after I compile it. There are no errors mentioned.

But when I directly jump to certain rackspaces in my gig they don’t react anymore. It looks like the scripting engine crashed.

The interesting thing is, that the script is 100% the same in all rackspaces. I copied it from the first working one into all the others to exclude a writing error. All the defined variables exist in all rackspaces.
The other thing is that I can always fix it by opening the script editor and pressing the compile button again.

Maybe there is a mistake in the script or a way to write it more efficiently but for me it looks like a bug.

I attach my script below.

Thanks for your attention!
Christian

//$
// DO NOT EDIT THIS SECTION MANUALLY
Var
DelayVolume : PluginBlock
DelayPlugin : PluginBlock
OrganVolume : PluginBlock
OrganPlugin : PluginBlock
KeyscapePlugin : PluginBlock
KeyscapeVolume : PluginBlock

//$

// Called when a plugin block parameter value has changed
On ParameterValueChanged(parameterNumber : integer, parameterValue : double) from OrganVolume
if parameterNumber == 0
then SetPluginBypassed(OrganPlugin, parameterValue end

End

On ParameterValueChanged(parameterNumber : integer, parameterValue : double) from DelayVolume
if parameterNumber == 0
then SetPluginBypassed(DelayPlugin, parameterValue end
End

On ParameterValueChanged(parameterNumber : integer, parameterValue : double) from KeyscapeVolume
if parameterNumber == 0
then SetPluginBypassed(KeyscapePlugin, parameterValue end
End


#2

Can you compile the script in each rackspace?


#3

This looks not OK
SetPluginBypassed(OrganPlugin, parameterValue end


#4

@superkargo You are missing the actual value < 0.1
Take a closer look please :wink:

    SetPluginBypassed(OrganPlugin, parameterValue < 0.1)
end

#5

Carefull
On the blog https://www.gigperformer.com/bypass-plugins-automatically-when-volume-is-off

The last screen capture, the script is not showing all its content…


#6

What exactly do you expect should happen?

Are you seeing a crash report? If scripting engine crashes then Gig Performer will crash… you cannot infer from “script doesn’t work” that “script engine crashed”

So do they always work in specific rackspaces and always fail in other specific rackspaces? Can you reproduce the problem with a gigfile that just has two rackspaces in it and a minimal number of plugins?


#7

Sorry guys… something got lost when I copied the script itself. Here is a screenshot showing the script I use in all rackspaces. Please let me know if you can find any mistake.

Again:

  • It works in the first backspace when I start GP.
  • It works after I press the Compile button
  • It doesn’t work when I direkt select one of the rackspaces in the middle.
  • I can then reactivate it by compiling it it in this rackspace again.
  • I compiled every rackspace on its own.

My intention is, to bypass 3 of my plugins when the volume control is down.

Thanks again for your help!


#8

You keep saying “it doesn’t work”. WHAT doesn’t work? What is actually happening or not happening?


#9

There is two “mistakes” typos"
line 17 < 0.01
and
line 31 < 0.01

it should be < 0.1
The parameterValue variable will always be a value between 0.0 and 1.0


#10

As I said, the script shall bypass 3 of my plugin. It works well after compiling.
When I select one of the Rackspaces in the middle the script functions don’t react anymore. No plugin gets bypass or unbypassed anymore.


#11

I´m not sure about that. Actually 0.1 was too high for me (the audio level was already too high then). That’s why I tried a lower value which works better.
But I also thought about that and changed these values to 0.1 in every script and in every rackspace. The problem persists.


#12

Ok, sorry it makes sense; by looking it was the only “odd” thing there.

@superkargo can you zip your gig file and upload a dropbox link to that or similar?
I’m puzzled trying a similar script.


#13

But what do you expect to happen when you select a rackspace? The values of everything will be the same as they were last time so why would you expect anything to be bypassed or unbypassed if it was already bypassed or unbypassed?


#14

@keyman Here is a link to my file:


Thanks for your help.

@dhj What the script is doing, is to automatically bypass and unbypass the plugins depending on the volume fader position. But the bypass parameter doesn´t react anymore. And this is a problem when you decide to turn on “keyscape” for example, because it will not turn on again. I have to switch to the backview and enable it manually again.
The idea is to keep most of my routings the same in every rackspace. And when I decide to use one of the instruments or effects I can just turn up the volume instead switching to the backview during playing.


#15

@superkargo I loaded your gig and if I lower the volume of “ORGEL” or any other ones that you’ve there they do get bypassed properly.

I 've tried 4-5 rackspaces at random.

Which version of Gig Performer are you running exactly?


#16

@superkargo

We’ve asked several questions earlier in this thread that you have still not answered – imagine you go to the doctor and asking him (or her) to cure you but you don’t explain exactly what is wrong.

So for example, you say, “But the bypass parameter doesn´t react anymore” —

  1. Which bypass parameter?
  2. To what is it not reacting?

Are you saying that when you are in a specific rackspace, the volume fader for that specific rackspace does not change the bypass status of a plugin? If so, in which rackspace is this happening?


#17

@djogon I´m using version 2.6.2 on MacOS High Sierra.
I can reproduce it here by jumping to the Rackspace “Roundabout - Strophe” for instance. None of the Plugins in the script are reacting on the bypass trigger anymore there.

@dhj: You are funny :slight_smile:
to 1: The parameters are named in the script!!! I´m talking about the bypass of “KeyscapePlugin”, “DelayPlugin” and “OrganPlugin”.
to 2: The parameter reacts to the volume fader of the GP Gain Plugin that follows the respective plugin in the signal flow. Namely these are DelayVolume, KeyscapeVolume and OrganVolume.
So as you can see in the script, every plugin got it´s individual gain plugin that should control it´s bypass.
It generally works in every rackspace after I compile it in that single rackspace. So I thought the script is okay. But after switching between rackspaces it stops working.


#18

So are you saying that you
A) Switch to a rackspace
B) Adjust the fader control of that rackspace
C) Nothing happens?

If you add a Print statement into the callbacks , e.g.,

On ParameterValueChanged(parameterNumber : integer, parameterValue : double) from OrganVolume
Print("Called with " + parameterNumber)
if parameterNumber == 0
then SetPluginBypassed(OrganPlugin, parameterValue > 0.1)
end

Do you see that in the script log window when you adjust the fader?


#19

@dhj Now you got what happens in my gigfile.

I added the print statement to my Organ and compiled it. I did that just in one rackspace (#19) of the gig. Now:

A) All functions of that script are working well at first. In the log I get “Called with 0” messages when I move the volume fader.
B) I switched to rackspace #1. No script related functions are working.
C)I switched back to rackspace #19. The scripts don´t react as well. The log still shows “Called with 0” when I turn the volume.

So it looks that the trigger is working but the “SetPluginBypassed” function doesn´t react.


#20

Are you doing anything beyond just switching to that rackspace and thenback?