Rig Manager Issue on Migration to New Laptop

I think I am so close to getting my new laptop fully working, but I can’t figure something out about the Rig Manager settings.

Sorry to repeat, but I have two keyboards I use: Casio CTK-7200 (non-weighted main midi controller) and PX350 (weighted and gives me added keys to work with). I have multiple sets of these two keyboards I use for rehearsals, etc. so I don’t have to tear down keyboard rigs (So, I am grateful the Casios are less expensive).

So, when I copy a Gig file from my current laptop and open it in my new laptop, it is very close (it seems) to working perfectly, except as follows.

My CTK-7200 seems works fine. I controls the rackspaces it should control.

But, when the Gig file is opened, the PX350 is not triggering the mid input block. It lights up the correct device in the Rig Manager, but it is not triggering any sound. (I cannot remove the device from Rig Manager).

But, if I change the midi block in a rackspace to “OMNI” it works!

However, I do not want to change all the midi blocks to Omni because then it will not work right on my old laptop.

I am guessing I am missing something obvious. (I don’t want to modify the Gig file in a way that it will not work right with my “old” laptop).

Thanks for any insight into this.


Do a test:
Right click on the MIDI In block and in the popup menu choose “Change MIDI Input Device” and in the upcoming list choose your rig manager device.

The PX350 is greyed out.

It works if I switch “Omni”, but I think it will not work on my “old” computer if I change all the (similar midi blocks) to Omni.

But, maybe I should try that. I thought I did try it, and it didn’t work on my old computer, but there is a chance I didn’t do something right.

It seems like the new computer wants to use “PX350” for the midi input block but the new computer wants to use “Omni”.

But I am probably doing something wrong.


Can you show screenshots of your rig manager?

And is PX350 enabled in the MIDI Port Options?

I can get you pictures, but in the meantime, the Rig Manager lists the following (in addition to Local GP Port) on the new laptop:


The enabled midi input ports say the same thing.


And both are now connected to your GP machine?

I am starting up my old computer now.

In terms of my new laptop, both keys are connected.

With the old laptop, the CTK is connected. But, I am using my PX350 on the new computer. (I guess I could attached another PX350, but I didn’t think I would need to do that.)

Okay, my old laptop just finished loading. I can check settings (but the PX350 is not connected to it right now because I have it connected to my new laptop).

[Thanks for helping with this].


Here is a weird clue. The CTK7200 got disconnected and then the PX350 started working.

Could there be some setting that only 1 device is recognized at at time?

I am going to restart it with only the PX350 connected and see what happens.


1 Like

Is gig performer the only program using the ctk7200 and px350?


To the extent this may be relevant, the CTK7200 is connected directly to a USB C port.

The PX350 is connected via a hub (which has always worked fine for me).

Its really weird.

I connected the Mid In Blocks I use for the PX350 to MIDI In (CTK-7200) (2) and it works perfectly.

It does not play the sounds made for CTK7200 mid input block, I guess because I restrict the channels (CKT-7200 only uses channel 3 and PX350 clocks only us channel 1)


It seems like whatever I do, the old laptop uses CASIO USB-MIDI with the CTK7200 and CASIO USB-MIDI-2 with the PX350.

The new laptop uses CASIO USB-MIDI with the PX350 and CASIO USB-MIDI-2 with the CTK7200.

I am getting confused.

It seems I can get each laptop working perfectly on its own, but the Gig files do not work right when I use one with the other laptop.

so the solution is rig manager
use the midi device alias in your rackspaces and at the beginning learn your physical device to the correct midi device alias in rig manager

1 Like

Paul, I don’t think that is it… I think I tried doing what you said. It does not seem to work. I think I tried every possible option in the Rig Manager and it did not do the trick. (I’ll go back in tomorrow and write in exactly what happens when I try to get this fixed in the Rig Manager).

It seems the only way to get the PX350 input blocks to work correctly on the new computer is to change the input to CTK-7200 (or Omni). Then it becomes CTK7200(1). So, I did that.

So, I just opened that gig file in the old laptop and the PX350 mid input blocks (now named CTK7200(1)) did not work.

So, it works if I change the midi input block to PX350. But, then it won’t work in the new laptop.

It seems any change I make to it work in one laptop makes it so it does not work right in the other laptop.

Maybe I have to also use the same Rig Manager file…? (Which are not stored as part of the Gig file, as I understand it).


Thank your for your continued help, Paul, and everyone.

I am going to set up both rigs with both keyboards attached to try, again, to figure this out. (So this time I will not have to disconnect and reconnect my PX350).

It seemed like, in my new laptop, the Rig Manager would not let me assign the keyboards in a way that allowed the Gig File to function the same way as it did on my old laptop. But, I am probably missing something.

My understanding is I should be able to get this to work without changing midi inputs in rackspaces? So, I should just be able to modify settings in the Rig Manager on the new laptop so the Gig file functions the same way as my old laptop?

I will methodically try to work through this. If I can’t figure it out on my own, I will post pictures to walk through exactly what I am doing how GP responds so can get further input.


I don’t quite understand the problem — assume your keyboards are defined with alias names of K1 and K2 (say) and all your MIDI in blocks use those alias names, then when you go to another machine (or another set of keyboards) you just open rig manager, double-click on the K1 alias name (which puts it in LEARN mode), press a key on whatever is your physical K1 keyboard and that should be mapped. Then do it again for K2 alias.

That should be all you need.

Thanks for chiming in, David!

I will run through everything and let you know exactly what is happening.

I don’t have much doubt it is user error somewhere on my end, but I haven’t figured it out yet. I will follow up.


Here are pictures from the two laptops. Using the same Gig file and the same rackspace (for Just the Way You Are), which has one sound controlled by PX350 (Lounge Lizard Rhodes) and one controlled by the CTK-7200 (VG Sax).

When I originally opened it up, the PX350 was (incorrectly) triggering the sax part. So, I “successfully” swapped the two keyboards in the Rig Manager.

Now the proper alias lights up when I hit the key on the corresponding keyboard.

As of now, the PX350 works fine (playing electric piano for Just the Way You are.

BUT, no sound is triggered by the CTK-7200.

Here are pictures.

A few more pictures…