Pops and Crackle then VI Stops working

Hi - I am on a Mac 2019 16" i9 Laptop 2 Terabyte internal drive with 64 gig of ram. My library drives are the OWC Thunderblade 40 gig transfer rate and my cables are also. The UAD Apollo x8p and x4 with a satellite attached is my audio interface. Digital Performer 11 is my front end for recording midi and playing tracks. I like to be able to pull up the piano roll to see my parts if I haven’t played a song in a while for reference and I can also go deep into the editing right after recording. This is why DP is my front end using the IAC bus to access GP patches.

I only have three patches in the gig file I am having the problem with. I have raised the buffer in GP to 1024 which causes latency when playing. Before I even start playing I hear a pop and my Falcon synth with an arpeggiated patch just goes out and will not play. The meter inside Falcon slams to the top and won’t play the patch. The mixer meters are all the way to the top also. If I quit GP and restart it will play for a moment and then overload again. I hear a pop when I quit GP. Here is a Pict of the patch.


When you bypass Falcon, then no issue.
Any chance to check if Falcon has an issue for example in Logic?

I just tried it in Digital Performer within the same sequence still patching through to GP 4. Falcon is totally fine in DP but still overloading and blowing out in GP.

I think I loaded Falcon as a VST 3 in GP. Could that be the problem? Which is the best for compatibility on a Mac, or have a smaller footprint - AU, VST or VST3?


I have used Falcon often on an older Mac with no issue. Something is configured wrong somewhere. What sample rate are you using? What does GP’s CPU meter say?

Also, that it works in DP proves nothing, particularly if you’re playing back a track since a DAW can precalculate what audio it will need to produce and so doesn’t have to be 100% real-time.

The UVI people have generally been very accommodating and helpful - you might want to reach out to them and report this issue.

It’s definitely worth trying a different plugin format. Only takes a minute.

I don’t think there’s a simple answer to which plugin format is best for compatibility or anything else.

Because VST has been around longer than VST3, the VST versions of most plugins have been through more debugging, but generally if I have problems with one format I try another and see what works best.

1 Like

Tried the audio unit version and that fixed the problem.

VST version shouldn’t give you a problem. Something else going on.

Hmm, All I did was change it out for the audio unit version with everything else stayed exactly the same and it worked. I had a problem with Omnisphere where the VST showed a list of parameters that I had no idea what they were. There was no GUI to even find out what the name of the patch was. I switched it out for the audio unit version and I got the GUI back.

From Omnisphere I know that effect with the AU version, you had that with VST?

Which version of Omnisphere are you using?

The VST works fine with Omnisphere. I have probably performed an update since the GUI problem so I am on the latest version 2.7.0f. I haven’t tried it again since the VSt is working just fine.

I am confused, which version faces the GUI issue?

It was the audio unit that had the problem the VST works just fine

What was interesting is that originally the audio unit was working fine and Out of the blue I couldn’t get the GUI to come up anymore and that’s when I switch to the VST which works. Maybe it was a previous update. I haven’t tried the audio unit again since everything is working fine.