Parameter scaling midi controller prob

Hey there, new user question. I’ve assigned a widget knob to control the volume on an audio mixer in the program. I am trying to get that controlled to an external akai keyboard. I’ve gotten it assigned, however, it doesn’t go from 0 to 100 in increments, rather just goes from 0 to one hundred, nothing in between . The parameter scaling is set to min 0.0 and max of 100. Not sure whats up with that I’m a bit confused, any help would be greatly appreciated!

What do you See as incoming Message in the global midi Monitor Window?

Hey there pp, when I turn the knob it says
0 ADVANCE61 Port 1 CC 14:127 Channel1

pardon me rather CC9: 1 Channel 1

ok, could it be that your hardware knob is setup as relative controller?
Relative does not work out of the box.

You should see increasing CC values.

What is your Hardware - Controller?

By the way @Kester.

Welcome to the family :wink:

Hi it’s an advance 61 keyboard. Do you know where I would change it so it can change the values properly? Great to be here!

Akai :wink:

How is the exact Name of that?

What controller are you moving?

Just for testing: try to Map the pitch wheel to your widget.

Seems,. it is relative (found in user guide)
7. Encoders: Use these 360o knobs to send MIDI CC or Increment/Decrement messages to your software or external MIDI device.

See page 32
https://www.akaipro.com/amfile/file/download/file/283/product/7/

Ok will do I have the bigger version of that one which is the advance 61. Looks like same mapping just less keys. I was mapping it to the first dial on the top right portion of the keyboard. I’ll try the mod wheel. I’ve got to wrangle my daughter for a bit hope to get at this in a little bit! Thanks!

OK, so the mod wheel works with the widget so I’ll have to tweak the knobs it I bet somehow.Ill check out the info on pg 32. I’m also finding that when I assign buttons to bypass certain plugins, they only ever turn on and not off. Am I missing something? Sorry I am on day one of this program lol

1 Like

No problem, feel free to ask.

We all here are willing to help.

Bypassing turning on and off makes sense.
What should be in between, fuzzy logic?
Maybe bypassed?

Or do I miss something?

There is a comprehensive online manual that you might want to peek at
https://gigperformer.com/docs/GP4UserManual/index.html

Hey Piano Paul, they turn on, but not off. I assign the button widget to bypass, and when I hit it, it bypasses, but when I hit it again to engage the sound, it does not turn off. I think I’m missing something?

Ok you expect getting CC Value 127 it should go on
and then again CC Value 127 it should go off, right?

Try this setting:

Hey that worked!! Thanks so much for the tip, the momentary to latching seemed to do the trick! Many thanks!

2 Likes