Omnisphere 2.6 Issues?


It seems since updating to Omni 2.6, sometimes the incorrect Omni multi is loaded. I can’t find a pattern just yet. I’m still using GP 2.6.2 at the moment.

For example, I was just creating a new “template” for my setup in which I initialized an Omni multi (it was the last rackspace in the list of 60+ rackspaces). When I clicked on the 4th rackspace, Omni loaded correctly. But, when I switch to the 5th rackspace, that initialized Omni multi was incorrectly loaded.

Luckily, when it happens at a show, I have been able to quickly launch Omni and load the correct multi.

I will be upgrading to GP3 in a few moments – maybe that will solve it :wink:

Just installed GP 3.2.7. Will report back after some testing in the next few days!

Still some multiple issues after upgrading to GP 3 (Win10). I’ve verified that all instances of Omni are 2.6 – all rackspaces have at least 2 instances of Omni running.

  1. Omni still randomly loads the incorrect multi file – still can’t find a pattern.

  2. Omni randomly loses its normal Mapping Params list. This first image correctly shows the “nLevels” for the 8 parts. Just to note, the Learn function works correctly in this case

    Sometimes, the Mapping Params list doesn’t have the “nLevel” entries. And, the Learn function stops working.

  3. Perhaps, related to #2 (?) – when multiple instances of Omni are inserted, it seems the 2nd instance never gets the “nLevel” entries in the Mapping Params list.

  4. After fixing a rackspace, I have been exporting them individually. When I came across an incorrect multi load and missing Mapping Params, I re-imported the rackspace, and it loaded the correct multi and the Mapping Params were fine. [Yes, the 2nd instance of Omni’s Mapping Params still no good.]

I will rebuild my gig file using the newly exported rackspaces…to see if that helps.

Sorry for the long post :wink:

Testing Omnisphere here on Mac

I am using Omnisphere 2.6 and Mac and until now I did not face any issue in Gig Performer 3

I have had this issue before. I have not been focusing on this nor testing it, but if memory serves, it seems to me that I have not experienced this lately. What I have done is:

  1. Enable host automation on a multi and configured it the way I like.
  2. Right-click on the blue background. In the polo up menu, choose MIDI Learn and Automation, then “Save Template.”
  3. With each subsequent Multi I create, I load my template and save my multi with the template assignments active.

Again, I am not sure, but I can’t recall having parameters lose their assignments since I started doing this (which is why I have not been trouble shooting the issue). Hope this helps!!

Thanks – I’ll see if that helps!

Ah – I think that may solved the Mapping Params issue on the 2nd instance!

I am seeing similar issues on Win GP3. Suddenly the multis in rackspaces were off by 1 (rackspace 1 started with multi 1, rackspace 2 started with multi 2, and so on), and after closing and reopening the gig rackspace 2 had multi 1, rackspace 3 had multi 2, etc. the pattern stopped somewhere, but it was during soundcheck, so I quickly had to reselect the multis in each rackspace.

I’ll try technique above to avoid losing mappings. However, this is something I just started seeing. Hopefully I’ll have more time to troubleshoot and save copies of the gigs if it continues happening.

Interesting re: multis off by 1 – hopefully I’ll remember to test again this weekend. Thanks for jumping in.

Beautiful…that did the trick for keeping the MIDI assignments. Strange that this is just now an issue, though…I only started seeing this last week. Thanks for the info

I faced the loading Issue with Omnisphere and Gig Performer.
The sounds within the loaded multi have been totally wrong.
Then I rebuilt the sound and saved the multi within Omnisphere (I did not before).
Since then I did not face the issue again.

Sounds like Omnisphere is not properly providing its state to Gig Performer to save or is not responding properly to the request to restore state.

You should report this to Spectrasonics

Will do that.

Whenever I made a bunch of edits to rackspaces, I would save, and reload the gig file – that also seemed to work much better. I hadn’t really a chance to really test again.

@pianopaul – thanks for submitting to Spectrasonics.

Are you still facing the issue?
I contaced Spectrasonics, they are working on that, but until now without a result.

No, but then again, I haven’t made any edits lately. I’ll probably be working on some new stuff this week – I’ll report if any issues.

Seems the issue with Omnipshere 2.6 only occurs when predicitve load is enabled and VST version is used.
When predictive load is disabled then the multis or patches are loaded correctly.
AU Version is working even when preditctive load is enabled - but this was not a complete deep test.

I talked to Spectrasonics support, I am not sure if they do change something as the predictive load is a unique feature of Gig Performer.
Maybe I can convince them to talk to the developers of Gig Performer.

Just got this from Spectrasonics:

appreciate your patience – I heard back from my developers and they let me know that they were able to isolate an issue, and will be providing a fix for this in the next software update. I don’t have an expected date for that release, so in the mean time, I would recommend using the AU version of the instrument.


Ok cool!