New Mac, my GP (-start instance) scripts are nolonger shown in the title bar. Whats to do?


i´m on macOS Ventura now / migrated my whole system from macOS Monterey to a new MacMini.

i run some start up scripts for GP, as has been posted here @GP Forum by @rank13.*
These scripts are still there, in: “Library” / scripts /
=> But NOT shown in the title bar

What do i have to do, that these will show up in the title bar again ?

  • These allow me to open up GP directly => from the title bar.
    This way, i have direct access to open up a GP instance either as arm-native or rosetta2 based, with just one click.

You have to enable this in the Scripteditor settings:



Much thanks tripleB !

but: i´ve just donne that now, following the instructions from that link,
(incl. a restart of the mac) and its not working. It shows me nothing in the title bar.
Guess, now, help ´s gonna be harder :laughing:

(hope its not a OS ventura problem)

No, no Ventura Problem - I’m on Ventura 13.2 as well :wink:

Sorry, German macOS…



Danke, bin auch german-speaking, hehe. (and my mac menu prompts :wink: )
This should help.

i never ticked the most upper box.
the second box, i had ticket at first, then took it off, cause i thought its just the two last ones to tick/click.

very good, i know now at least that Ventura is ok.
Can try it this evening.
much thanks !

1 Like

Bitteschön :slight_smile:


I´m back at my new studio PC.
Tryed again. It did again not work out.

i think, best is, i move over to the mac forum.
I have now enough information and overview, to ask the right questions.
i´ll let you know when things work. Thanks for the hand !

the problem has been solved.

its a thing of “rights”.
respectivly have i added the scripteditor to the “startup/power-on enabled” apps.
(stumbled over that by coninsidence)
Then activate it finally by starting GP. This adds it to the title bar.

Great ! Thanks

1 Like