Midi In Not Working, But Works When Replaced With New Identical One

I’m hoping for some help here.

I started my Lenovo (bigger computer), which I used for the Livestream today.

I thought I just had to reset the keyboards in rig manager and did so.

My CKT-7200 is working fine.

With my PX350, I can’t figure it out. It is set up right in the Rig Manager.

It does not make a sound when triggered. I see Global midi on the proper midi channel (Channel 1)

But, I dd not see midi when I insert the midi monitor between the Midi in block and the sound source (Lounge LIzard)

Here is the weird thing. When I replace the MIDI in block with the same MIDI in block (PX350) it works!

It’s like it resets it? I do not see any difference in the settings between the midi in block when i start and the midi in block I replace it with.



[I am starting to suspect its about MIDI Alias, which for some reason I could never wrap my head around].,

Do you have numbers after the MIDI Port name, which would indicate it might have changed from the original port name that the gig file was saved with?

I think I fixed it, but do not fully understand what happened.

I just did a quick replace of the (what should have been) the PX350 to make sure it is PX350 and it seems to have fixed things everywhere.

I need to run through everything since I have a gig tomorrow and I am planning to use Lenovo.

So, I may not be able to follow up this evening. But, thank you!


My guess is a never set this up properly with aliases, but it never mattered before because it always stayed connected to the same keyboards.

But, now I have decided I want to start using the Lenovo out to see its bulk bothers me. If it doesn’t, I will probably fully retire to Dell and get another Lenovo. Then hopefully I will not need another laptop for along time.

You should really use Rig Manager.

1 Like

I do use Rig Manager on both my old and new laptop. On my old laptop, if somehow the keyboards got switched, I could just swap them out in the Rig Manager.

But that did not seem to work with the Lenovo (which has not been moved from my rehearsal space since I got it).

It seems like I had to swap (correct?) the midi input device in all the racks.

[Note, in my set up one keyboard always uses channel 3 and the other keyboard always uses channel 1, for reasons not worth going through in this thread].


Something seems to be wrong in your setup, the issue you have is something that is typically solved in seconds in Rig Manager. You should exclusively use MIDI in port defined but an alias name. Probably that you started to do that and removed this kind of MIIDI in port by others only defined by they hardware. Please show us your Rig Manager config and the kind of MIDI in port you have in your Rackspaces.

Everything seems to be working now, But, of course I have not disconnected anything. If there is a problem, it would arise (at a gig) when took everything apart (to travel) and set up the rig.

Thanks for looking at this. I think (hope) this is now set up right, like my Dell XPS was (which I had not had a problem with).


It seems so, yes.

FYI, rather then “associating a MIDI device” choosing it in a list, you can simply “learn a MIDI device” and press a key of the controller you want. But, you probably know this and simply wanted to show the available devices in the list…

1 Like

Thanks, David.

Yes, I was trying to show the window. But I’ll take any help I can :slight_smile: . Sometimes, the terminology confuses me a bit.

Hopefully the Lenovo is now set up right for the gig this evening and going forward. I think this will be be main laptop going forward and maybe keep the Dell as a secondary backup.