Midi devices conflict in GP?

Hello, I’ve been experiencing a strange problem with my midi keyboards: When I connect the first one (all directly over USB) it will work. The moment I connect another one the new one will work but the first one will stop working. Same when I connect a third one: the first two won’t work anymore. This is instantaneous, a played note won’t stop since the right note-off signal is missing. GP will still tell me in the messages that all the devices are connected though.

This only happens sometimes and doesn’t happen on other host applications I use. Please help :slight_smile:

Can you tell us what the hardware is? Computer, keyboards, any usb hubs?

Also, are you using omni-in midi blocks? Using the rig manager?

What about other DAWs? Same behaviour?
My first thought: Maybe the USB power breaks down… if you can, try an active USB-hub (with separate power supply).

Are you talking of several identical keyboard controllers or several identical MIDI-to-USB adapter?

This is my first thought, too.

My second thought is that he needs to optimize his Windows a bit and especially check the power features: Introduction

My third thought is that there is a weird USB name changing conflict - Gig Performer | USB MIDI Port names keep changing on Windows

2 Likes

It could also be nice to tell us what exactly “works”. What happen if you open the GP Global MIDI Monitor and play some notes on each of the keyboard controllers?

The devices will work as expected but when they stop working there will be no more MIDI input from the respective device.

To follow up on the general issue: The configuration I experienced this problem in first was with two keyboards directly connected to my laptop’s USB ports and another one connected via my docking station’s USB port. However, yesterday I had the same issue with only two (directly connected) keyboards and the problem seemed to be a faulty controller (Arturia Keylab 49 Mk I) which started to send random MIDI signals and then caused my other controller (NI KK S49 Mk I) to stop working in GP. I haven’t tried to replicate this issue in another host environment and won’t be able to since I literally threw the Keylab in the trash right away. I use a lot of Arturia software but I’m not thrilled with the build quality of these things.

However, the entire issue is still a bit of a mystery to me since as far as I understand the management of these MIDI devices as signal sources happens on an entire different level than the MIDI protocol. Well, let’s hope I’m done with this problem for good.

2 Likes

So, unfortunately the problem is back. Again, with two keyboards attached to the laptop and one to the docking station. The latter one works, the former two seem to be working but there’s no MIDI coming into GP. I close GP right away and opened Ableton Live and everything works flawlessly there.

Any possible explanations for this? How can I approach this issue?

Can you please @mangolassi reply to the above questions? One by one… right!

  1. Novation Impulse 49, NI Komplete Kontrol S49 Mk. 1, Roland RD-64. I run a PCZ Recoil laptop with Windows 10 and have a Dell docking station connected that I use as a USB hub for the Roland since all physical USB ports are in use.

  2. Yes, I use device aliases for the former two keyboards in the Rig Manager. Some rigs use the omni-in midi blocks, some device-specific midi-in.

1 Like

Can you try with a dedicated USB hub?

You mean with all MIDI keyboards attached to one hub?

Yes. :slight_smile:

Okay, sorry for the long waiting time but the result is exactly the same. I attach one keyboard and it works fine, I attach the second one and the first one goes dead. It’s still shown as connected in the Rig Manager but there’s no more MIDI input. It happens regularly now, so it has turned into a major problem for me.

You didn’t mention the history of this issue. Did they all work for a long time, and this is just a recent occurrence?

You mentioned you got rid of one of the keyboards - what was it replaced with?

How much testing have you done with other DAWs? I think it will be most likely to be a windows/hardware issue, so it will be good to try and replicate the problem with other software.

My casual research has found:

  • Never ignore the simple things like bad cables. They are also the easiest things to swap out.

  • I saw a few mentions that some controllers have problems connected to usb3 ports. What are yours? Was the hub you tried usb2?

1 Like

I was just going to mention that also…:+1:

1 Like

If you play a key on that keyboard, does the entry for that keyboard in the Rig Manager flash?

Maybe I should describe the issue again because right now I have a pretty clear picture of the issue:

The problem doesn’t occur if I connect all devices first and then start GP. It only happens when I (re-)connect the devices while GP is running. I connect one keyboard and it works. I connect the other one and the first one stops working, i. e. there’s no more midi input from that device in GP.

I tried the same thing in Ableton Live 11 and it doesn’t happen there. I can de- and reconnect the keyboards as I will and they will always keep working correctly.

The cables are not the issue. I tried it either way and the problem occurs regardless of which cable I plugged in first. I had the same issue in my rehearsal room and I use totally different cables there.

I think the USB ports on my laptop are both 3.1 and the ports on my docking station are 3.0. This is however nothing I am able or willing to change and since this is exclusively an issue in GP from my perspective I’m confident this is not the root of the problem.

No.

5 characters

I’ve just reviewed this entire post so some questions

  1. Did it ever work?
  2. What version of GP are you running?