MIDI assignment problems

MIDI assignments deactivate upon launch. I will save them before closing and then when opening the saved file, some midi assignments are ok, others aren’t and I have to remap them all. Regardless of that, in the midi assignments window, they show as mapped but they do not work.

Second problem. I mapped FX on off switches to buttons on the top of my midi keyboard (using AXIOM 49, buttons 1, 2, 3, 4, A, B, C, D,). Again, I will program them, everything is fine, when I close and reopen, they are now mapped to switch songs. Look in Global MIDI, nothing is assigned for that. MIDI assignment window shows them mapped to the FX switches but when pressing them, they don’t engage but skip to other songs.

I have looked into the AXIOM 49 itself to see if my default, those corresponding buttons are assigned to default song changes, they aren’t. So I have no idea what is happening.
When trying the demo version of this software, it didn’t do any of this crazy stuff, which led me to purchase it. Now it’s doing all of this! I contacted support and they said there were no known issues and I should try the forum.

Can you please describe exactly what you are assigning and how? We need more details to see exactly what is happening? For example, how are you assigning a MIDI message to a widget? Are you associating the widget with a plugin parameter?

Are you on a Mac or on Windows? How is your controller connected? Also, can you run the Global MIDI Monitor and provide a screen shot for one control so we can see what is being sent out?

This is important information.
There is absolutely zero difference between the two versions - it’s the same executable. So if it worked properly when you were in trial mode and is now failing (somehow), then something else has to have changed on your system or on your controller. There’s no magic :slight_smile:

Don’t get me wrong - not implying any magic whatsoever. It was meant more as a joke of irony, I know, hard to come across in text.

I’m on OS X, 10.15 Catalina. MIDI controller is connected via USB (port 1)

I am assigning FX on/off switches via a Native Instruments plugin. I assign them via Edit mode, dragging the widget over, using the learn functions. Opening up the plugin, making sure I see the changes in the plugin window.

Provided screenshot - I now see the extra midi message. Not sure why it doesn’t show in any other view I tried, both the keyboard itself, and the MIDI assign windows.
Screen Shot 2021-09-24 at 12.19.59 PM

OK — what you are sending there is a bank select message (CC 32 and CC0) followed by a program change.

Those specifically cannot be learned — they are intended specifically for controlling Gig Performer itself (selecting rackspaces or song parts, etc)

ah damn ok - maybe one of these days, I’ll get myself a new midi keyboard… until then!

Thanks for your help

OK - so is that the ONLY issue you were having?

What exactly were you trying to accomplish (that worked in Trial and is no longer working)?

  1. Which controller? (exact reference please)
  2. Which button/knob of the controller?
  3. Please move a button/knob of your controller where this « issue » happen and display the GP Global MIDI monitor at the same time and do a screenshot that you will post here.
  4. Show us the widget properties of the widget you try to MIDI learn (screenshot after learning please). Does it control the learned widget properly?
  5. Show us what changed here after saving and reloading.
  6. Could we please have a screenshot of your MIDI assignment window?

With a few more info, for sure, we will be able to help you :wink:


Yes. The button assignments did work in the trial no problem and worked upon purchasing. With no skipping around of the songs. But you had said that theyre not assignable because they are meant for controlling songs so, it’s all good. I’ll live with it!