Issues with loading plugins - VCV Rack, Captain Plugins Epic

I recently purchased Gig Performer and am running into issues loading some plugins. The following plugins are loading correctly on my Windows 10 machine and running without issues, but they are not loading at all or crashing Gig Performer on my Mac M1 Air running MacOS 11.6.6: VCV Rack Pro VST, Captain Plugins Epic.

I ran into the same issues with latest version 4.5.8 downloaded as a trial from Deskew site as well as the version 4.1.5 version purchased through Plugin Alliance. For VCV Rack, I tried to revalidate the plugin a number of times but it’s failing to verify. It loads correctly on my Windows machine. Is there a way to force loading a plugin. The error in the Plugin Manager states that it was deactivated after failing to initialize?

For Captain Plugins Epic, loading the VSTs causes Gig Performer to crash. The AUs on the other hand load, but not responding to transport.

All these plugins are working correctly in the following apps: Ableton, Bitwig, Kushview.

Try starting Gig Performer under Rosetta.
And do a rescan of failed plugins.

Thanks, I’m currently running Gig Performer under Rosetta, and having the same issue. Have run a rescan a few times, and for VCV Rack, it’s still not activating.

Did you delete the red entries in Plugin Manager and rescan?

Yup, also did that a number of times.

Below is the crash report for Captain Plugins VST as well:

Application Specific Information:
Crashing on exception: The window has been marked as needing another Layout Window pass, but it has already had more Layout Window passes than there are views in the window.
<JUCEWindow_b251c7fda2ad9983: 0x7fabff4289a0> 0x3597 (13719) {{0, 98}, {16909, 682}} Rackspace : Captain Melody Epic en

Not sure what that means. :confused:

You should contact the Plugin Developer
and send him the crash report.

Given that the plugins work fine in multiple other apps, could it be an issue in GP?

No not really.
Gig Performer is more demanding on plugins because it is a realtime Host.
Ableton or Logic are not designed as realtime hosts and therefore some buggy plugins are working,
but they do not in Gig performer.

In my experience when you give a plugin developer this crash report they are glad about, because you found a bug they have not been aware of.

By the way, did you get a complete crash report from crash reporter?

Yes, I can pull a full crash report if that would be helpful.

what i can add: (also M1mac / BigSur)

VCV Rack2 works here fine with GP, also 4.1.5 (under rosetta)

on my system, VCV was permanently crashing in standalone mode, at least at first,
but used to run fine within GP, from day 1 on. (i no longer patch anything in standalone, just use it to update modules. Had no further crashes since (standalone) )

so, i´d say, thats not a per se problem here (VCV vs. GP), but must be related to your system. Maybe deinstall and reinstall VCV ?

1 Like

Interesting, odd, thanks. Which versions of Big Sur and VCV are you using? I did try to re-install VCV but that hasn’t worked. I wonder if there’s a new or older version will work. :thinking:

Ugh, figured it out! I was using a beta set of modules that was keeping the VST plugin from loading properly. Once I removed it, VCV didn’t fail the scan anymore. Only had that beta on my Mac, not Windows, which explains why it was fine there. Thanks to everyone for their help! GP is awesome!


No — and I had also bought a copy of Captain Plugin and ran into the same problem.

When I queried them, I got the following answer from them - so they don’t particularly care. You might want to complain to them

I spoke to our development team. They said that since Gig Performer is aimed more at live performance, and Captain Plugins is not, it would be classed as lower priority in terms of fixing any compatibility bugs.

If I’m totally honest, unfortunately, it doesn’t sound like support will be added.

The crash is in the plugin — we’ve seen this one before. It is of the form

" [Layout] Unable to simultaneously satisfy constraints:

They need to fix it.


Got it. That’s fine, they work ok in Kushview and Ableton, so I can host them there. I’ll send them a note as well. I’m using GP more a modular host than performance tool at this point.

Please do – the more people that reach out to them, the more chance they will fix the problem.