Issue with Amplitube5 Parameter Automation

Check the video. Correctly assigned Controls are suddenly being reset to 0. Randomly, and I cannot reproduce the logic. Sometimes happens when switching Variations within one Rackspace, more often when switching Variations between different Rackspaces. I tried all Controller and Parameter settings I could find in AT5 or GP and can’t fix it.

My suspicion is some internal “Reset all Controllers” Trigger, but no idea really.

Any ideas how to bugfix this?

Could you share that rackspace with us here so others can try?
Also - can you reproduce this with a different plugin?

1 Like

Hi. Never had this with a different plugin. I think it might be an issue by Amplitube. Also I had an occurence where I reopened a saved gig file and the assignment of Parameters in AT5 was lost.
Rackspace attached.

AT5_AUTOMATION.rackspace.zip (10.6 KB)

There’s nothing unusual there so that leave only a few options…

  • Somehow you are sending a program change message into the plugin which is resetting the values
  • You use predictive loading and the plugin is not handling it well resetting the values
  • The plugin has a bug and resets its parameters when it gets bypassed

The third option sounds like the most likely one unless you are using the predictive loading stuff.

1 Like

I wouldn’t know. I don’t think so.

Nope. This setting is disabled.

Hm, that must be it then? How would I go about that? Basically no automation of AT5 can be used then, right?

…however I wonder, would that be the case when it’s happening sometimes, but not always, randomly?

It would indicate a bug in that plugin then. We haven’t seen that happen with anything else.
The randomness of it is the biggest issue. It will be VERY hard for people at IK Multimedia to figure out what’s going on.

Most DAWs do not do what GP does - switch the rackspaces and. activate/deactivate plugins etc… so it will hard for them to debug this.

I’d still report it to them and see if they can maybe fix it.

1 Like

When you remove the other plugins in that rackspace, does the issue still occur? I tried to reproduce for 10 minutes straight using your rackspace and one of my own, switching back and forth between rackspaces and variations. I couldn’t reproduce what happened to you. I don’t have the other plugins in that particular rackspace however(just Amplitube 5), so if I were you I would simplify the rack down to just Amplitube 5 and see if it occurs. If not, add the other plugins back one by one until you reproduce.

1 Like

I just tried with two different rackspaces and only AT5 in each of them, automating just one parameter and had it within 2 minutes again
So it cannot be related to other plugins

Interesting.
Have you updated to 5.0.1?

yes 5.0.1 since today

one more thing I could try is use the VST3 instead of AU

Does the behavior occur with a different pedal also (like a delay)?

In my second test I tried amp presence, so no OD pedal

I see.
We’re on different platforms (you on Mac, me on Windows), so obviously I can’t entirely replicate your setup. It could be a Mac-only issue for Amplitube 5.

Ah yes - absolutely. Parameter handling is different for those formats and it is quite possible that the bug in the AU version is not present in the VST or VST3 version and vice-versa

1 Like

It seems the issue does not occur in VST3

I’ll do with that then

3 Likes

I’d still report it to them so they can maybe fix it in some update. The fact that it works in VST3 will help them

1 Like

yep, thanks a lot for all your help!