Issue with ADSR Drum Machine

I’m trying to use ADSR Drum Machine ( but it won’t load and ends up as a failed plugin in the Plugin Manager.

I have tried reinstalling it, but with the same result. This is on Windows 11 and it only comes in the VST3 flavour.

Has anyone else had issues with this plugin?

Have you tried rescanning failed plugins several times in a row?
I have encountered this problem with a few plugins that ended up being ok.

1 Like

I rescanned once initially and then again after reinstalling the plugin, but I’ll give it a go at rescanning a few time in a row

I’ve tried rescanning multiple times, but no luck, it still won’t load. I have contacted their support email to see if they are willing to sort it out mentioning that the GP team are very responsive to helping plugin devs sort out compatibility issues.

I did some Googling and did find that apparently Reaper has issues loading this plugin too.

Yes, the plugin fails a scan for me also.

1 Like

Just tried. Cannot validate.

1 Like

Hmm, if other hosts are having problems, not much point in doing anything other than waiting for the plugin developer to respond

1 Like

Indeed. I hope they do respond.

Just to update the thread. The support person was responsive and the developers have now released v1.2 which now intiliazes correctly and works within GP4.