Inconsistent LINK behavior

I have three instances of GP running, and utilize the LINK functionality to sync tempo between them.
Often times, when pressing the LINK button on each instance, the first two will link, but the 3rd will not. There doesn’t seem to be a rhyme or reason to the behavior. Sometimes it links properly on the first try, and other times it will take numerous attempts to get the 3rd instance to link. Below is a short vid showing an example of the erratic behavior. (it works properly on the first two attempts to link all three instances, but the 3rd attempt fails.)

Any thoughts on what’s happening, and/or how I can get a more consistent LINK behavior?

I tried to reproduce on Mac, issue does not occur.

Possibly an issue with the Windows version then, since it reproduces every day here.
It’s not a big issue, as I only need the links to work once per session for all three instances. Just curious what could be the reason behind these seemingly random occurrences of third instance link failure.

Options > General
Does it change if you have Sync Start/Stop selected?
Remember each instance of GP has its own, exclusive settings.
Screen Shot 2020-07-29 at 11.37.29

Thanks for your reply.
Changing the Sync Start/Stop option on all the instances has no effect on this particular issue.

1 Like

Thank you @edm11!
Just for the record, you’re on what version go GP?

@David-san can you please take a look?

I’m using 3.7.1

1 Like

I checked this on 2 laptops and a desktop (all Windows), using old gig files, and then new gig files. Same erratic result.
So for me, the repro steps are:

  1. Open GP
  2. Create 2nd instance
  3. Create 3rd instance
  4. Press LINK on Instance 1
  5. Press LINK on Instance 2
  6. Press LINK on Instance 3

If all 3 LINKS are successful, then un-check each LINK and repeat the steps until Instance 3 doesn’t link with the other 2. I am able reproduce with ease on each of my machines.

1 Like

I can’t reproduce this on windows 10. LINK uses networking to communicate - is it possible there is interference from your firewall software even though it’s the same computer?

Do you have other LINK enabled applications that you can try?

1 Like

Thanks for the reply.
I checked on my main PC, created an allow exception for GP in Windows Firewall.
Still the same result. The firewall wouldn’t explain why it works most times, but then fails others. It wouldn’t work any of the time if the firewall had a rule to exclude that sort of communication between apps.

I’m using ASIO Link Pro as my source of multi-client ASIO, so I wonder if that is the reason why you can’t reproduce. That’s the main similarity between my 3 machines, which otherwise have very different configurations and still all reproduce the same results. Very odd.

If you use it on these 3 machines separately - does it work then?
Also - do you have any other LINK software on your computers? If you do - you could check if those fail as well.

I tried with Ableton and 2 instances of GP, couldn’t get it to fail within 20 attempts.
So far it’s only failed on 3 instances of GP, and only on the 3rd instance. The first 2 instances always link properly.

If by ‘3 machines separately’ you mean to network them, that’s not something I do, as my music laptops aren’t connected to networks.

It may be something in the LINK libraries. We’ll look into updating them at some point. Thanks