GP requires midi inputs to be replaced on Win 10 rebuild


#1

Because of certain glitches and odd things happening in GP, I decided to rebuild my Win 10 os. Now I find that when I boot up GP, many of the midi inputs don’t trigger instruments anymore. If I just right click and replace, they work again. If I just had one or two rack spaces, it wouldn’t be a problem. But I have well over 200 and it takes ages to go through and fix them all up. I’ve had to do it before a couple of other times. I’m just wondering why this happens when everything else in the rack is ok.


#2

Not sure what does it mean to “rebuild” windows, but reinstalling/updating drivers etc… could result in your Windows reporting your devices with a different identifier.
As far as GP is concerned - this looks like you connected different MIDI devices to it and, of course, the specific MIDI in blocks will not work - you have to replace the device.

When you do however - the GP asked you if you wanted to replace ALL MIDI in devices in ALL rackspaces the same way. If you answer yes - it would all have been done in a few clicks.

Don’t want to get into Rig Manager at this point, but there are some very nice bulk operations that you were actually asked to do - is there a reason you don’t take advantage of that?


#3

Do you have an example with a single rackspace (say) that demonstrates these “certain glitches and odd things” happening?

This notion of rebuilding windows (whatever that even means) to address such issues is confusing to me. Obviously I can’t know for sure without far more information but if GP itself was responsible for these “glitches and odd things”, we would expect to be seeing similar reports from many hundreds of users. So other than an errant VST, we are left to suspect that something about your specific hardware and/or whatever you’re doing in “rebuilding” is in fact the cause of the problem rather than the way to fix whatever is wrong. It may be that there’s some faulty subsystem/RAM/peripheral or some other software (like an anti-virus that periodically triggers something) that’s breaking things.

We have no way to determine this and that’s why there hasn’t been an “official” response.


#4

Rebuilding a computer means reinstalling the operating system then reinstalling all the programs. The term “rebuilding” is one I hear PC computer techs use all the time.

I never got the offer to replace all midi devices in all rackspaces the same way. I have seen that message before, but not this time.

Yes I know I have been told about the Rig Manager, but frankly it scares me due to my lack of understanding. Will the Rig Manager work on an already created 260 rack spaces? Or is it only intended to be used as rackspaces are built up one by one?


#5

Sorry, I forgot. No I can’t recall what the glitches were now as I didn’t write them down.


#6

Every time you right click on a MIDI Input block and select “Change MIDI Input Device”, then select a new device you are presented with this:

06%20AM

After you select “Yes” - you are presented with this:

19%20AM

The only way you wouldn’t be asked these questions is is you maybe use v1.x of GP which did not have this functionality.

Did you maybe use the function to replace the entire block rather than just change it’s device?


#7

Yes, I tried again and did get the message. The midi block already had Desktop selected (greyed out) which is the one I want., So do I select another then reselect the Desktop one again which is the one I really want?


#8

If the midi input you want is already selected it should be working if that input is connected to the system.


#9

I agree, but the OS rebuild has broken the connection. The only way to get the midi block to receive midi again and to pass it on is to replace it as I mentined at the start. My previous host never did this. If I ever had to reinstall the Windows OS, my songs always worked. GP has broken all the midi connections.


#10

As far as I know, the only way that could happen is if the rebuild changes the underlying names of your devices. But then we are back to why you have to rebuild in the first place. Maybe there’s an underlying issue with your MIDI devices…dunno.

But the whole point of the Rig Manager is to isolate such changes so that you can just reassign a physical device with an aliased name and all midiblocks will then just work and so all rackspaces will just work.


#11

GP did not break anything as far as I can tell. Your system seems to be doing it and GP actually has a nice way of dealing with the problem. Actually - more than one way of dealing with the problem - the bulk changes and the rig manager.

Can you reliably reproduce this claim and show that some other host magically works while GP isn’t? Please note that we are NOT talking about OMNI inputs which GP has as well. If you use OMNI input any device connected will just work.

Also - based on this claim it seems that you were rebuilding/reinstalling the OS on your computer all the time for a while now even before you started using GP - is that true?


#12

Could you please mention the MIDI interface hardware you are using?
I would also be curious to SEE some SCREENSHOTS of each step, from the point where your MIDI in block doesn’t receive anything, to the point where it works again.

David

PS: by the way “reinstalling” your PC means reinstalling everything (OS, drivers, applications) in your PC! “Rebuilding” means that you compiled source codes for this, which could be the case with a Linux system, but probably not with Windows 10.


#13

Hi Davis-San,
The midi interface I have is a NI Tractor Audio 2 Mk 2. I bought it because I move around a lot entertaining and the device is very small about the size of a pack of cards so is easy to carry and set up. And it is bus powered.
Thanks for the explanation between Rebuilding and Reinstalling. I reinstalled the os according to your description. Here in New Zealand, most of the computer techs I have met call reinstalling rebuilding.
I’m not sure that there is anything to show from screen shots. When a rackspace won’t work (ie a midi start command sent from my iPad over wireless won’t start my drum vst) then I know the midi connection is broken. So I right click the midi in block, then click “replace plugin.” Then the next time I send the midi start command from the iPad using a bluetooth foot pedal, the drum vst starts playing instantly. So I know the connection has been restored. No message appears on the screen, so that’s why I’m not sure that screen shots would show anything of value.


#14

Yes I agree with you - Windows has broken GP which in turn has broken the midi in blocks connections. My bad for getting the wrong names here.
I’d like to say at this point how much I love using GP. It has such a great interface and is really fun and easy to use. It is disappointing to me to have to fix things up after an OS reinstall. I guess I’m a bit paranoid over Windows, having been brought up from Win 78 SE in 2002. OS was unstable in those days for audio and the drivers available not good, so I was always reinstalling everytime I suspected Windows was playing up. Looks like I need to get over that attitude and start trusting Win 10 more. At some stage, someone here will need to reinstall their Windows OS, so I hope they will be better prepared than I have been. At the moment, I have a very kind forum poster helping me understand the Rig Manager. When this has sunk into my thick skull, I hope to never have to do the fixing up again.


#15

I would bet with 95% certainty that that connection is breaking due to a problem with your wireless/Midi interface.


#16

Thanks David. I’m using the free rtpMidi. Do you know if there is something better ie paid for?


#17

rtpMidi is supposed to be very good but that’s just the PC side of things. Unless you’re seeing Gig Performer warning you that the MIDI device disconnected, that is not where I think the problem exists. I’m more inclined to suspect the actual wireless part of your system. You say you are sending messages from your iPad to your PC. How exactly is your iPad doing that? Are you running a network router to which both your PC and your iPad are connected? If so, is your PC connected by WiFi as well or is there an Ethernet connection?


#18

I use a Apple Arport Express router. I install Apple Bonjour on the PC and rtpMIDI is the link that allows the iPad to talk to the PC. Both the iPad and the PC are connected to the Airport Express network. I do have Bome Network which I guess is an rtpMIDI replacement, but I haven’t figured out how to use that. I’ve never tried an Ethernet connection from the Airport Express to the PC because it doesn’t have an ethernet port (I use a Surface Pro).


#19

As far as I know, the purpose of rtpMIDI is essentially to enable MIDI over a wifi connection. However, if there’s a problem with the wifi connection itself, that would cause a problem. Apple airport routers are pretty old and it’s unclear how reliable they are — I’ve seen a lot of flaky ones in the day. Do you know what frequency they’re running at and on what channel? Do you have other wireless routers in your environment?

I’m wondering if you notice the problem more in particular places (e.g, in your home studio vs at different venues). You’re going to get a lot of problems with interference from other devices.

Again, you need to answer a particularly important question I asked earlier — GP displays a “fading out” dialog whenever it detects a MIDI device being connected or disconnected. Are you seeing that dialog?

Here’s an example that happens if I pull out the USB cable from one of my keyboards. It displays for a moment and fades out. If you don’t see this, then GP is still seeing the MIDI connection but MIDI isn’t arriving, which suggests an issue with your connection from the iPad to your computer.


#20

First of all, thanks very much for sticking with me and helping me work through these problems. Amazing support really​:heart::smirk:
I’ve never seen the fading out effect you mention. And regarding different venues, I don’t see any difference in wireless performance. I have the Airport Express set on the 5 ghtz band And the channel has automatically set itself to 157. I used the Airport Utility on my iPad to do this. Good to know that the absence of the fading message means that GP is receiving. I do have problems with the iPad app called OnSong at times. Occasionally it will glitch and despite the midi commands it is sending, GP will not respond. Usually I have to delete the song on the iPad and completely rewrite it from scratch. This generally fixes things. With all the complications I add into my songs via midi, I guess it’s inevitable that things won’t work at times.