GP Rackspace Variations not responding to midi program change

Hey Everyone, so I’ve spent hours on this now so I figured I’d reach out and see if I’m missing something obvious.

I simply want to use Forscore to change my GP Rackspaces when I select a song. When I launch the midi monitor window, I can clearly see that I am sending the following:

CC 0 Bank Select 1 Channel 1
CC 32 Bank Select (fine): 1 Channel 1
Program change 9 Channel 1

I have a rackspace and have it set to Bank 1, Program Change 9.

In Global Midi Options, I have tried checking/unchecking “Ignore bank switch” and “Pass unused PC messages” in every combination I can think of.

Any thoughts would be most helpful. As a side-bar, I also tried sending bank/program from the RD-2000. Again, the midi monitor shows it coming in with the same data but the rack space variations don’t change. I even tried to go into Setlist/Song mode and assigned the same numbers there and nothing changes in GP.

Thanks so much in advance!


You do not have PC numbers for rackspaces, only for variations.
try “Use zero-based PC numbers” in the Global MIDI sections of the preferences window.

Hey Paul,

Yes, I did mean 'variation and not rackspace. I re-created my connection on my mbpro and did check the Use zero-based PC Numbers" option and I’m now able to change patches from my iPad. Thank you!

1 Like