GP Loading freezes on Pianoteq 8, Why?

For the past few weeks Gigperformer keeps getting stuck on Pianoteq 8 when loading. I don’t understand why. What should I be looking for to correct this?

If you start a blank gig and just load Pianoteq, does it still get stuck?

You should be looking to contact Modartt !

I’ve seen some crashes with Pianoteq 8 but 6 and 7 were ultra reliable.

1 Like

This just happened again at 40% loading.

I will replace the 8’s with the 7 and see if it makes a difference.

1 Like

please report back !

hmm, i´ve had recently also several very unexpected crashes.
This “could” indeed coinsede with the Pianoteq V8 update.
since i have 1-2 PT instances in quasi any of my Racks.
its at least in 90-100% of my Racks vs. Each single Gig.

its very hard for me to understand whats going on, since i am still test-patching with new software all the time. All i know is i have significantly more crashes with GP.
bevore was it VERY little, close to none. Now its completly different.
( but i went also thru two PC changes within short time, Mac, each coming with a new OS)

Not good if i can´t trust PT any longer.

replacing V8 with V7 would be an insane amount of work for me !
i have *everywhere" two PT instances on a crossfader, incl. bypass widgets.
thats quasi per rackspace ! on each Gig same.
plus the restore of chosen sound presets…/ Not a work i really intend to do

Thanks for posting @Stringchaser ,
it gives me at least an idea of what could be the cause.
Thats allready a plus

Modart has a pretty robust forum as well. Probably should detail your concerns there and maybey link that post here.

Both the VST and VST3 versions of Pianoteq v8.0.8 load very fast, and run with no errors, on my Windows system. If there’s a problem, it’s apparently on Mac only. Is the latest Pianoteq version for Mac also 8.0.8? Which Mac OS version are you running? Which Mac silicon? Are you running under Rosetta or native?

1 Like

I made a gig file with Pianoteq 8 and loaded it with no problems on my late 2014 Mac Mini with Monterey.

1 Like

Whenever this has happened to me it was because the USB cable to the drive holding the (in my case) sample data was not connected properly (I know Pianoteq is physically modeled). Might as well double check that.

RE: i really don´t know if PT causes any problems here, or not.
I have no indication as such on this.
Just, that this thread made it look like => “a thinkable possibility”.

i not only have crashes, i have several Gigs i nolonger can load.
These worked allways in the past.
I was very surprised to see this the other day, whne s everal Gigs would not load, but crash at startup-
i thought i had ruled out my 1-2 problematic plugins.

PT is in fact in every of my Gigs present, and probably also in over 90% of all my rackspaces.
This could absolutely coinside and be related with my PT 8.0 update.

PT could indeed be here the common denominator. This is absolutely thinkable.
I don´t have more, its just that…it´s even not a real guess.
(just “a possibility” / the only one i see so far )

i deal with more than dozends of Gigs. Much likely a 3 figure number.
So, having overview of not loading Gigs is a bit hard.
I can start now to keep an eye on it, gather such Gigs together,
then when a pack of not-loading (or crash at startup) Gigs is together, deinstall PT8, and see if someting changes.

also is nearly every patch i do since end last year incorporating completly new plugins.
its very hard to get an idea what happens here.
and i´m on OS Ventura / new mac since idk. 10 weeks or so. Or 14 weeks.
So, all of a sudden, i deal with several new variables.
But all new plugins are only present in one gig file. and not in old ones.

so, the initial post here has just triggered something…
I love Piantoteq, to make this clear.
As sayed, it is in much more than 90% of my racks present.
But thats also, what worrys me here so much, if you know what i mean. :wink:
Thanks for trying to help !

I just installed Pianoteq 8 on a new PC and decided not to include the stand alone app in the install because I never use it. Gig Performer crashed on load trying to validate. I reinstalled including the stand alone app and validated through that and no more crashes.

1 Like

What about the freezing issue?

Sorry, I have not had any freezing issues with Pianoteq 8 other than while trying to validate which it could not do and then would crash GP.

Well, all bets are off when the plugin is doing its own license validation but sounds like everything is good now.

a longer time no crash/freeze at startup vs. GP,
now, i just had another one.

see screenshot please. Taken when @ freeze.
this would indicate it was Pianoteq 8, right ?

edit: i just tryed to follow aboves tipp, to deinstall the standalone.
just: the deinstallation ends with a error message

edit: ok, i threw it in the basket, reinstalled it, thought i had an option to de-select the standalone, but there was nonne. How to get rid of PTeq8, standalone ?
just throw the Pianoteq8 Folder, in: Programms, to the basket ?

sorry, for hyperventing !
but when GP begins to struggle, do i hyperventilate. so used to it, that things “just” work !

to notes vs. my hyping: i´m originally a computer hater.
Wonderful Pianoteq brought me back to Computer.
And Fantatstic GP finally made, that ITB could overtake my whole music making setup.
But things MUST work.


the same problem here on M1 Mac, VST3 version of the plugin. It seems that it occurs after Pianoteq update to 8.0.8. Still does not work with the newest 8.1. update. I have requested Modartt support for download link to 8.0.7.


1 Like

Tested 8.1 VST3 on M1 Mac Ventura, no issue.

1 Like

here, i´m under the impression that my GP startup freezes are related to running two GP instances.

ok, i go and contact moddart too. Thanks for Feedback !

I have just upgraded to Ventura too. Problem persists…