GP doesn't recall my Variations when I send Program Changes

Hey guys,
hope someone can help me out.
I don’t know what I’m doing wrong.
Basically, I’m unable to switch to a variation on GP by recalling it with a PC message
I can see the Program Change message on the MIDI Monitor Screen of GP
But the variations don’t switch/react to those PC messages.
I have tried sending messages from three different devices:
My DSI Tetra, My Digitakt, and my MC6
But no luck so far, I can see the messages on the MIDI Monitor window but the variations don’t receive the message…
I know this is pretty basic but can’t figure it out even after reading the manual…
Cheers

What does this section of the Global MIDI Settings page look like for you?

517

Can you please do a screen shot of your MIDI Monitor when you send the program change? By any chance, are your devices also sending bank switch messages?

Thanks for your response!

Please see below:

Many thanks for your help.
I think they send the Bank too yes…

Please see below:

59 45

Thanks!

Alright, I don’t know what has happened but today GP responds to my Program Changes…
Even though, yesterday I restarted GP and the computer several times…
Weird stuff!
I probably had some kind of voodoo thing going on in the studio yesterday…
Much appreciated for your help :+1:

I can’t figure out what it was…
The interesting thing is that GP responds to all the PG I send from all my devices even when sending the PG on different Banks…

How is GP handling the Banks of the Program Changes?

Cheers

Can you show a screenshot of the received Bank Select messages in the MIDI monitor?

yup

01

So the bank select messages are not sent out before every PC message?

It seems bank and PC are two different messages right?
can you send the bank and the PC in one single message?

Yes


No, but you can send them directly one after each other.


What I’m getting at here is that bank select messages instruct the receiving device to switch its bank. The receiving device (GP in this case) is only in one bank at a time (not in multiple banks per device where the bank select command came from).
So,if bank select and program change messages can have a significant amout of time between them, a situation like this can occur:

Device A: Bank Select 5 => switch to bank 5
Device B: Bank Select 3 => switch to bank 3
Device A: Program Change 23 => switch to program 23 in bank 3 (this obviously happens even if there’s nothing in bank 5

Could something like that be the root of your problem?

Bank messages (CC0 and CC32) are totally independent of PC messages. Gig Performer will remember the last bank switch message it received and then program changes sent by themselves will be assumed to be associated with the last received bank message. So if your rackspace bank value doesn’t match the last received bank, the PC will be ignored.

When you restart Gig Performer, the default bank is 0 which is why everything started working again.

1 Like

That’s probably the case.
however, i restarted GP several times yesterday including the computer with no luck
i even clicked on the “ignore bank switch commands and map to bank #0” option (Global MIDI)
and that didn’t;t fix the problem…
Nevertheless, it works now! :star_struck:
Thanks all for your support

Hmm, that doesn’t make sense - if you’re able to make this happen again, reproducible steps would be much appreciated.

sure, i’ll keep an eye on this
thanks!