Gigperformer4 crashes on Close


Sorry to bother you again. Last year I reported that Gigperformer4 crashes on close, creating on entry in the application log of Windows: Gigperformer4 crash when closing

At that time, first I thought the issue was resolved by deleting a particular plugin. Later on, however, I discovered the issue was still there, but, as I seemed to be the only one experiencing this (and thus feeling special :grinning:), I decided to not report it again.

Now I have not so good and good news:

  1. Not so good news: The issue is still there
  2. Good news: I have pinpointed the circumstances under which this issue occurs

When the following option is selected, the issue presents itself:

When the option “Auto open/close plugin editors” is selected, and Gigperformer4 is closed, these entries occur in the Windows Application log:

To me it is not a real issue: I can deselect this option while I can do without it, and otherwise I know there might be some error logs, and then I might need to remove these. But knowing you people at Gigperformer, you want it just to be perfect, so I report it.

I attach a Windows Error Report for some more information:
Report.wer.txt (19.4 KB)

Hope this helps and thanks for creating such a neat and fantastic tool!

Thank you for reporting this. We’ll take a look and put this into our bug tracking system.


Do you have Supercharger (comes free with Komplete start) installed? Because I had the exact same issue: GP4 would crash when closing. After I removed Supercharger from my PC the issue was solved.

Do you have a GPScript or Scriptlets running in you gig file? :face_with_monocle:


Just an empty, really empty gig. To make sure, I switched off loading the last gig, started Gigperformer and dismissed the offer to create a new gig by using a template.

Then, just close the program.

@Seet Nope. No supercharger here, sorry :grinning:

@David-san @Seet

It only occurs when the option I mentioned is selected. Luckily I can really live without it. Furthermore, one cannot see it crash: Only the mouse pointer changes to busy for a short while after closing Gigperformer. I found out because I was writing my own vst plugin and was checking its shutdown-behavior and thus also checking the Windows event logs

Thanks for your suggestions, however

So, Gig Performer doesn’t crash - it exists normally.

And the only symptom you see is “busy mouse” for (say) a 5 seconds + Windows Events log entry is created?

If anybody else can’t reproduce, then this has to be something on your system (e.g. corrupted files, damaged runtimes, outdated Windows).

Do you have Gig Performer installed on another PC? Does it happen there?


No. Please, do not jump to conclusions. It does crash: please look at the screendump and the report.wer.txt. Windows error reporting catches it in the background, so Gigperformer crashes but you do not notice it, but it crashes nonetheless. I’m not trying to keep you busy with nothing.

All I’m trying to tell is that the problem is not that big. It is not that the world stops turning. No pressure. I’m trying to be nice :grinning:. You don’t have to drop everything and go debugging right away​:grinning:. I would not dare to expect something like that from you. I hope you get my drift…

(wer: Windows Error Reporting)

My Windows is not outdated, although it is running Windows 11. Drivers are up to date.

But the crash can simply reproduced by turning on this option. So please try that first and look into the Windows Event Log, application section.


Of course :beers:


I do not drink :beer: or :wine_glass:, but I appreciate your comment.

To double check: I’ve installed Gigperformer4 on my wife’s laptop, in trial mode, that is. The issue also occurs on that laptop under the same conditions: option on → crash, option off → no crash.

I repeated this several times. That laptop has a different cpu (i5), runs Windows 10. My wife is not into daws and so on. The only plugins are the ones installed by Gigperformer: lostin70s and TH-U-64

So, my laptop is not that special anymore :thinking::grinning:


Thank you for the detailed feedback. :slight_smile:
I marked @djogon 's answer as the solution.


I agree. Thank you. Have a nice day/weekend/life

1 Like