Error writing to file...An error occurred while trying to save <filename>

I’m on the latest version of GP4.
I keep getting the above error message when trying to do a “save” the first time. I click “ok” and then try again and the message does not come up and it’s saved. Why is that?

No idea!

What are you trying to save? The Gigfile? To where?

Do you have any kind of anti-virus tool running? Does Gig Performer have permission to access whatever folder to which you’re trying to save? Were you using an older version of GP4? GP3? Are you using our version or the one distributed by Plugin Alliance?

Here are the steps which I take (and I can simulate this consistently):

  1. Launch GP4 (downloaded from this site - not Plugin Alliance). It opens my “Tonic Pads Gig”.
    (file : Users/Patrick/Documents/Gig Performer/Tonic Pads Gig.gig)
  2. Then click “File” and “Save” and the message will appear (exactly) as follows:
    — “Error writing file…An error occurred while trying to save “Tonic Pads Gig” to the file:
    /Users/patrick/Documents/Gig Performer/Tonic Pads Gig.gig
    Couldn’t write to the file” —
  3. I click on “OK”, message disappears.
  4. I immediately do a “File” and “Save” again. This time no error message.
    Note: After that, the error does not happen again no matter how many times I “save”. It ONLY happens the first time I Save after launching GP4.

Configuration: Mac Air (M1, 2020), 16Gb

To answer your question: I turned OFF Bit defender and Yes GP has permissions to my folder because it saves it successfully AFTER the first try.
The strange part is that it only gives me the error on my FIRST “Save”.

I have also tried a Save As and gave the gig a new name. Reopened successfully. But again, the first SAVE will give me the error message on the new file.

Thanks for you help in troubleshooting this.

Are you using the GP4 ‘Universal’ installer for Mac?

If so, have you set it to use Rosetta?

This definitely looks like some kind of permission issue on your system.
Can you try to use ant text editor and save a file into that folder, then perform the same test and see if it gives you the same error message?

@rank13 … I used installer for Mac OS, not Universal.

@djogon … I opened a new text file with and save in the gp folder. Reopened, edited, saved. No Problem.

Additional things I did in trying to find a “pattern”. My test: QUITTING WITHOUT SAVING

  1. Opened the gig; Added a text label and tried to quit WITHOUT saving.
  2. GP re-confirmed before closing if I needed to Save before I quit. I clicked “YES” to Save… Got the same error.
  3. I repeated and tried to Quit a second time without Saving. GP re-confirmed before closing again if I needed to save before I quit. I clicked “YES” to save. This time… Successful.
  4. Double check and reopened and found that the added text label was successfully saved.

My result: First Save when GP4 is opened. Hits the error. Subsequent saves are Okay.

My next test is going to be: CREATE a NEW GIG altogether from scratch on this machine and this version of GP4. (Note: The above current Gig was created under a Previous Mac Pro laptop running Catalina. Securities, etc may be sllightly different? dunno.)

There are always new security prompts for OSX. There’s one for access to your documents folder - maybe check that and make sure GP4 has access to it

Hmm, if that was the problem, then why would Save work the second time?

Good point… not sure, but something is really strange with the disk access there. Maybe check the permissions on that file after you write it for the first time.

Did my next test: CREATE a NEW GIG. Same problem.
There was nothing but a rackspace + some knobs with nothing else set up.
Save first time fail. Second time Okay.

Note again: I’m on M1 Mac Air (2020).

Unless you changed something - I doubt things will improve. Also - did you check the permissions for that folder?

Here’s the first thing that pops up in google if I search for your type of issue

Documents not saving on OSX

@djogon Thanks for the suggestions. Permissions are okay; all “read and write”. I even set read write for “everyone” just to be sure.
Tried also the google link and followed as documented. The command did not fail, nor did it complete after I waited an hour; should not take so long. I terminated the terminal command. Rebooted.
Re-Launched GP4 and problem still persists.

Thankfully, this is not a showstopping problem, so there is no urgency per se.
Thank you all for trying to figure this out.
Will leave this open (for me) for now, and will try any suggestions.

Just for grins, could you try creating a new user account, run GP as that new user and see if you can save the first time?

@dhj Okay. The plot thickens. I did (just for grins, as you say) as follows:

  1. Created a new user (TESTUSER on Mac)
  2. Installed GP4. Activated it.
  3. Created a new gig.
  4. Saved.
    NO ERROR message. (What??!!)
    So it must be my user (Patrick) which seems to be the problem (??). Anyway, this works, so I subsequently deactivated GP4, and removed TESTUSER from Mac.

So now, I’m thinking it’s the user activation? So I logged BACK TO MY ORIGINAL USER (Patrick) and did the following:

  1. Moved my existing Gigs elsewhere (backed up).
  2. Moved GP4 to trash (uninstalled)
  3. Re-installed GP4 .
  4. Opened a NEW Gig from scratch.
  5. Added a few knobs.
  6. Save as…
    Sigh… same ol’ error came back.
  7. Save as again… Successful.

Now I’m thinking of backing up everything and RE-CREATING a user on this Mac from scratch. But then, man… that’s going to be a pain.

No, it’s clearly a permissions issue. But why did you uninstall GP? Also, did you install it for “all” users or for one user?

@dhj I uninstalled because I assumed that I had to “deactivate” and “activate” when installing. Just wanted to try to start from fresh.
Also, I cant remember if it’s for all users because I’m the only user and I don’t remember having to answer that. But knowing me, I’d probably have said “all” users because I’m the only user anyway.

To where are you trying to save your gigs?

“/Users/patrick/Documents/Gig Performer”

@dhj @djogon
So what I’ve done to “resolve” this is a workaround (Short of trying to re-start/reformat my entire M1 again).
I created a new user and saved all my gigs under the new user, then created aliases to tie them back to my regular user id “documents” folder. This works. And since I have very specific gigs, I only need to set this up once.
Thanks very much for all your suggestions and help in troubleshooting this. More or less know that it has something to do with my user and permissions but “repairing” this may be more trouble.
Nothing to do with GP4 as a perfectly working app.

1 Like

Problem is resolved (many thanks to @dhj).
Cause was the permissions. This has been rectified and GP4 working perfectly now.
No workarounds necessary.

1 Like