Dead rackspace (dead vst...)

I made a mistake…
I put a Roland Juno VST in a rackspace for a gig I will have in November.
That VST is not included in my Roland Cloud account, it was working as a demo.
Demo has expired and GP cannot load anymore the full setlist.
When GP tries to load the rackspace it blocks, and there is no way to work than killing GP.
I have there several songs already perfectly made, so I would like to recover what can work.
I tried to deselect those plugins (vst, vst3 and au) from plugin manager but nothing has changed.
Someone surely knows how to solve that.
Many thanks

Did you disable that faulty plugins?

That’s the way to go. Perhaps you didn’t deselect the “right” faulty plugins…

Did you quit and restart GP after doing that?

1 Like

Yes. I quit GP and launched it again.
GP is still trying to load Juno60 also if this plugin is off in plugin manager. So it blocks there… Really disappointing.
Any way to load rackspaces one by one in some debug mode?

Did you turn them off this way (see first image?)

That doesn’t make sense — if you turn them off and reload, they should show up as missing. There should be no attempt to load them. at all.
There has to be something else going on. Have you tried actually DELETING those plugins from your system?


1 Like

I put them off like you did in plugin manager.
But it didn’t solve. Tomorrow I will wipe them away from my HD.
There is a try to load missing plugins when you load the setlist, this seems to me the issue. Thanks anyway…

This might be dumb or off topic, but how long did you wait when it locked up? I had kind of the same issue after upgrading to GP4 and having some plug in changes. GP would just hang up. Same thing for several restarts. I got distracted by something else on my last attempt and was away from my computer for quite awhile and when I came back it had loaded but with the messages that the Manual said would be displayed for missing/corrupt/unloadable plugins (and just like the screenshots from dhj) and I was able to get it all squared away. Maybe you just didn’t wait long enough for it to resolve itself/load?

I think I waited hours, but I will give it a try…

Are you connected to the internet on that machine? If so, try disconnecting and then try loading the gig again

Solved. Probably my fault.
Dead vst (Juno-60 by Roland) was deleted from plugin manager but not disabled.
I solved rescanning everything in plugin manager and really disable all files about Juno-60: vst, vst3 and au.
Now GigP correctly mark that block in my rackspace as MISSING, avoiding any issue.
I must add that this Roland policy to install everything as a test, checking every week (or month?) and stopping not authorized plugins is really dangerous, and nefarious.
Only damages can come from that.
I am using only D50 and Zenology Pro but I will stop my Roland Cloud subscription if they don’t use more suitable methods


Hmm, if it was deleted from our plugin manager, it should no longer be available — I wonder if there’s a bug there.


Yep - I can reproduce this – ok - we will put this on tracking system


This is the first really interesting Roland plugin, but their lifetime key which necessitates monthly internet connection really sucks.

Actually this is now fixed for a future release – we should never have allowed an entry to just be deleted. You should either disable the plugin or uninstall it from your system and do a rescan.