Consequnce of Turning Off Controller During Seessions

So, I sort of absent-mindedly turned off my keyboard controller during a rehearsal. Before I started using GP sometimes I would do this just to clear out a setting. This synth starts up very quickly, so was no big deal.

But, I noticed that with GP running, the keyboard was no longer recognized by GP.

And, I was a bit surprised I could not just re-connect it in the Rig Manager. It would not recognize the keyboard when I double clicked on the alias.

So, I had to restart GP, which, as I you know takes some time (to load up the samples).

So, going forward, I will make sure I do not turn off the controller keyboard.

But, is this sort of expected behavior?

What could be seen in the global midi monitor when you played notes on the keyboards?

What should doubleclick help?

I double-clicked on the alias name in the Rig Manager and hit the key on the controller.

What happens with doubleclick?
Did you choose the menu entry „Learn MIDI device“?

If it happens again I’ll try that. But, I thought double-clicking on the alias is the same.

I think it lights up both alias for both keyboards, but does not connect the CTK7200.

(I tried to check that both aliases are set up right. When I look in the midi inputs (in the rackspace) for each keyboard, the proper keyboard (the one currently use) is greyed out, as I believe it should be. So, I think my midi input are set correctly.)

The underlying question is really whether your computer redetected the MIDI device. The Rig Manager allows you to map a physical device to a name but if the computer didn’t redetect the physical controller then there’s nothing that GP can do.

He said that after restart Gig Performer it was working again.

I often times power down my XK-5 and leave GP running. When I boot the XK up again there is a momentary lag but GP soon recognizes it and all is well.

Because I run scripts that utilize the XK, I have to recompile those but then I am back up and running, very easy.

I’m hooked up to USB midi, not DIN but I don’t think that should make a difference.

It sounds like maybe the connection loss was so quick that GP never detected the drop or never detected the reconnection.

Anyway… in practice there is no reason this should be a problem to turn off your controller and leave GP running.

I just saw this. Yes, if it happens again, I will take a look. (But I am going to try to avoid it).

Following up on Brandon’s point, maybe if I clicked on “Remove MIDI device association” and then tried to learn the device again (by double clicking and hitting a key or using the Learn MIDI device command) that would work to fix the issue without having to restart GP.

You shouldn’t have to change anything in the Rig Manager.

I’d conduct a test. Have everything setup as you like it, as it should be including your device fully aliased in the Rig Manager propertly. Do a contolled shutdown in ‘proper order’ by quitting GP, turning off your controller then reverse that for a boot. Does everything work correct when you are back in GP?

If so… now test just turning off your controller. Watch GP screen when you do this. It will print messages on the screen near the top indicating devices that are disconnected. It might report the keyboard and a midi interface, depending on how you connect your controller (USB vs. DIN via interface). After about 5-10 seconds, boot up your controller again. Watch the screen again, does GP print a message that the devices are re-connected? Is everything working correctly?

It should be. If not and if nothing else is changing then the only explanation I can offer is that your computer is not detectting the midi interface in the same way and it thinks its a different device. I’ve not seen this happen unless I change how I am patched to my computer. For instance, to your computer and therefore to GP, if you connect yoru keyboard via USB but then connect it via a DIN plug to a midi interface, your computer sees those as two different devices. In that case, yes you would then need to go to Rig Manager, click on the missing device and quickly learn it now you are connected to a different interface.

This should not happen if you are not changing your interface and just booting down your controller but there could be a reason… like a ‘smart usb hub’ or third party software interfearing but it would be the first I’ve heard of this.

So start small with the controlled experiment I outlined.

Turning off your controller is perfectly valid. Mine has tubes in it so I don’t leave it on. I switch it off and I sleep my computer 90% of the time without shutting down GP. I wake the computer, turn on the controller (click a button to recompile all my scripts) and boom… I’m back.