Can't Load Gig File

#1

I seem to have a pretty big problem. I can not get GP to load. It gets to about 60%, at rack 10 every time and I get an error message box saying “Unable To Open File… Unknown Error.”

When I click OK, I then get the progress bar stuck at 0% and GP is totally unresponsive. I can’t get rid of progress bar, load a different file… or anything.

I am not sure it is relevant but I’m quite sure that rack 10 where it stops has Kontakt 6 in it, which is not in any of the preceding racks. The Kontakt 6 standalone works fine and the .dll is there where its always been.

I tried restoring to just before the last time it was working (this past Sat nite) and still no luck.

I’m on Windows…Is there a way I can go in and disable or delete that auto load file? I guess then I could at least see if I can get GP running and further troubleshoot from there?

#2

Do you use Kontakt 5 in previous rackspaces?

#3

Actually I need to correct that, I remember there is in fact an instance of Kontakt 6 in one of the preceding racks. But no Kontakt 5 in any of the rack spaces.

I can’t think of anything unique in that rack where it hangs loading that is not in preceding racks

#4

Yes, there is :slight_smile: Just hold down the Shift Key during GP startup

1 Like
#5

Are you using Audiofile Player?

#6

I do not use Audiofile Player.

I was able to load GP holding Shift (thanks @simon!) and I can then load some old gig files when I was still building my racks and had not got to rack 10 yet, but none of the recent ones… they all stop at rack 10. Rack 10 has only VB3, Amplitube 4 and Kontakt… all of them are in previous racks, except the one previous Kontakt has a Scarbee Wurly and 10 has the new Scarbee ep88.

Really need some help here, this is big problem for me. Just in trying to troubleshoot this today GP has closed/crashed. Not sure why

#7

Wenn, these gigfiles are really just XML. I suppose, you could just try to remove the 10th rackspace from the XML tree and look if that helps.
If you don‘t know XML, I cold do that for you (it‘s a matter of a couple minutes at most), if you are willing to share your gigfile.

Disclaimer: I haven’t tried this myself before, so I can only suppose that this might work, but no guarantees :sweat_smile:

#8

Not overly familiar, but I do a little editing of my website so I’ll give it a try. thanks for suggestion

#9

So… that gig started loading again. Without me doing anything that I know of. Perhaps it had something to do with Amplitube? I was trying to demo the Amplitube Lesliei… and Custom Shop was telling me it was out of date and updated that and then it kept telling me the Authorization Manager was out of date and I was just going round and round in circles. But it was after I finally got that resolved that GP started loading gig again

But surely that shouldn’t have had that kind of effect on GP? There are instances of Amplitube in the racks prior to rack 10 where it stopped loading. Maybe that fact that it stopped at rack 10 all the time doesn’t have the significance I think it has?

So I don’t know what is going on but it is concerning me very much.

#10

Except you did do something, i.e. you dealt with amplitube licensing.

For what it’s worth, I would never insert a trial plugin in a gigfile that I actually need. Always run your trial plugins in their own gigfiles (or at least make a copy of your production gigfiles) to use. Even when you buy them, use them on their own for a while to make sure they’re rock solid.

#11

ok thanks I will know better next time, I guess. Still can’t appreciate how that screwed with my gig file. It finds and loads the vst or doesn’t, I would have thought. Licensing would let me open it or not or demo or whatever once loaded? But not allowing to load a gig file?

I do an did have backups but I could not open them either. Anyway my thinking was I’m not going to “save” anything i do, so wasn’t concerned about trying to demo Leslie. Btw, the rumors are true, VB3 II kicks ass through the Amplitube Leslie

#12

Well, if a plugin decides to connect to a server or try to do some license authorization while it is being loading, and it gets held up (generally because of a bug in license validation, for example, perhaps it couldn’t reach the server and just kept trying for ever without timing out), the host is stuck because it has to wait for the plugin to finish loading.

A decently designed plugin should always finish loading and then do its license validation in a separate thread. That way it won’t hold up the host.

But some plugin developers don’t think deeply enough about the consequences of their design and one can consequently get bitten.

#13

GP does odd things for me now and then. Sometimes when loading, GP reaches a gigfile then stops. If I click on the screen it goes entirely white. If I walk away for a few minutes, it may or may not continue loading. If it continues to hang, then I can delete and try loading again. When it finally completes loading, and I check the file where it halted, it is often a very small rackspace with only a couple of instruments loaded. Recently, a gigfile refused to load for me, so I had to import all the rack spaces (which fortunately I had backed up), into a new gigfile. Another thing that happens with me, is when I close a gigfile and try to load another almost straight away. Many times, a double mouse click will not load the gigfile and I end up clicking six, eight or maybe ten times before the file begins to load. I have reported these issues, but never really found resolution.

#14

Which version of Gig Performer?

#15

3.2.7

#16

Yes I understand and appreciate the explanation. I would have thought IK Multimedia played better with others. What threw me off is that it always stopped loading at same exact spot, so I thought it had something to do with that particular rack. And that rack didn’t contain anything that hadn’t (to my way of thinking) already been loaded in prior racks

#17

Hi LilyM. I was interested to read your comment about the ik Leslie sim working well with VB 3 2 which I have. I was thinking about buying one to try out rather than the whole set. Do you have a recommendation? Btw I’m having the same problems with Amplitude and Custom Show continually trying to update. How did you resolve that? Also, when the Leslie demo has downloaded, how do you get GP to see it? There isn’t an installer that I can find.

#18

This happens to me if i immediately try to open gp after closing it. I put it down to unloading sample libraries from ram

#19

@bigalminal I don’t actually know what I did. But I think when it said to update Authorization Manager I just canceled out and just basically ignored all messages. Open Custom Shop and go to Collections and you’ll find Leslie. I demo’d just the 147. You have to “try”.both the 147 amp and 147 cabinet.

Then you open GP and open Amplitube and click on preset window and again go to “Collections>Leslie>147” and that should do it.

Do you already have Amplitube? Otherwise you’ll get a demo with Custom Shop and white noise every ten seconds. Of course you have to have GP scan for the ampliuibe .dll

#20

If you’re testing effects plugins, take a look at the stuff from Overloud before you make a decision.