Can't duplicate a block in the wiring screen

I cannot duplicate any blocks in the wiring section. If I right click on any block (midi, plugin, etc) and choose “duplicate”, it says “duplicated” (or something), but there’s no duplicate block.

I’ve restarted the program, and rebooted my machine. No change.

Anyone having this issue?

Maybe it got duplicated but offscreen. Use the scroll bars to find if it is hidden out in the nether.


Did this ever work for you — if so, when did it stop working for you?

Also, @SteveC-Bome has a point — please check that it didn’t get duplicated by mistake somewhere outside your visible area although it’s unclear how that could actually happen.

Are you on Mac or Windows? What happens if you try to duplicate a selected block by pressing CMD-D (or Ctrl-D on Windows)? Does that work? In that situation the duplicated block should appear at your current mouse position.

What version of Gig Performer are you running? Can we see a screen shot of your wiring view?

I can’t explain it, it’s working again. The items weren’t being duplicated off screen, I scrolled all around and the duplicates were just missing.

It didn’t work all day, and now at 8pm tonight (PST) it all of a sudden starts working again. Even after reboots during the day…lol…

thx everyone

There’s no magic — something is going on and it’s probably worth figuring out what it is. I don’t think we check the time and only work after 8pm :slight_smile:

So when did it stop working? And when it stopped working, had you changed anything else about your system?

Update: it is intermittent on my PC (not just working after 8pm…). I can highlight a block, right click and choose duplicate, and it will either work or not. I’ve attached two small videos showing this, shot within 10 seconds of each other…Lol. I’ve verified that in the non-working duplication that the missing block is not off-screen or hidden anywhere. Bizarre.

When it happens did you try to do SHIFT+F? (zoom to fit blocks)

No affect using Shift - F

What version of Gig Performer are you running?

After you have tried to duplicate the block and it seemed to fail, could you please try just dragging the block away from its current position?

Newest version 4.0.54.

In the non-working duplication video (2nd one), I drag away the block I tried to duplicate to see if it was hiding underneath. It wasn’t.

Was it selected? Can you make sure to first click on the background to unselect everything? Otherwise you might just be dragging both of them (if indeed the second one was actually created directly on top of the first one)

Yes, in both videos you can see the broken lines surrounding the selected block that I’m trying to duplicate. Nothing else in either video is selected.

I just tried the experiment again. The first two times, the block would duplicate. The 3rd & 4th time it flashed “duplicated one block” near the top of the screen, but new block is there (even moving the block I just duplicated, and using Shift F, and searching off screen). Not there!

Can anybody else reproduce this?

After duplicating, can you then switch to another rackspace and back again. This is to check it’s not UI refresh/update issue.

Maybe try minimizing GP and then opening it again. This might be a video driver or graphics card issue that doesn’t properly update the display?


Switching rack spaces does not stop the issue. Neither does minimizing GP and reopening.

It’s just random and driving me crazy. Most of the time the duplicating doesn’t work at all.

My main laptop closely mirrors my desktop. Intel i9 running 64gigs of ram. It will duplicate most blocks, but GP4 keeps crashing when I duplicate a Kontact 5 plugin running a Sessions Strings Pro 2 patch.

Update: GP4 on my desktop also crashes when I attempt to duplicate a Kontact 5 plugin running a Session Strings Pro 2 patch.

I tried to, but couldn’t.

  1. Could please post the smallest possible gig file for which you have the problem? (many of us also have Kontakt/Komplete to try to reproduce)

  2. The only time I had GP crash after duplicating was after doing it many many times until I run short in RAM. What about your free RAM?

  3. When it fails to duplicate, could you try something like mapping a widget to the plugin you just tried to duplicate? Thus you will see if it is in the current Rackspace plugin list.