Bug report. Waves H-Delay BPM parameter


#1

Hi

I have just purchased GP3 for use hosting AU & VST Plugins as a live FX rack.

Am encountering an issue when using variations with Waves H-Delay Plug in.
I have mapped the BPM parameter to a fader and had reliable results while demoing GP2.
I have created 8 different variations which i recall via MIDI PC

However, after purchasing GP3 I am finding that specific parameter does not recall accurately. The BPM will be fairly randomly set to one of the values I have used, but not necessarily from the variation I selected.

All other parameters in the variation are recalling accurately. Only the H-Delay BPM is recalling the value from a different variation.

I’m running a Mac Mini OS X 10.9.5 with a mix of Waves & UAD plugins


#2

While at NAMM, we discovered a very stupid bug that sounds like it’s the same as what you describe where some values don’t get reset properly. That has nothing to do with BPM, which is why this just might be a coincidence.

We’ve already fixed it and will be releasing a minor update with this fix as soon as we recover from jetlag (so in the next day or two). When it’s out, please try it. If it works, great. If it still doesn’t work, then I’d be putting my bets on it being a plugin bug.

Appreciate your patience.


#3

Thanks for the super prompt reply!

Im not using the host BPM setting, and this worked perfectly when I demo’d GP2. So don’t think its a plug in issue in this case.

Hopefully the update later this week will be it.


#4

Ah, wish you’d mentioned it was working with GP2. Yeah, this is probably the issue we fixed. Appreciate your patience.


#5

umm, he didi :slight_smile:


#6

Yeah, I didn’t notice at first.


#7

Have installed the update 3.0.45
Initial test suggest that this has resolved my issue

Thank you


#8

Thanks for reporting back. It is always helpful when users mark conversation/thread as [SOLVED]. This helps others who may have a similar issue find solutions.
There’s a checkbox I believe that allows you to do that as the thread creator.


#9

Hi

I’m afraid the issue is still persisting.

I am attaching my gig file here for reference
.COOS FX 1.1.gig (118.4 KB)


#10

I downloaded your gig file and while I don’t have the UAD plugins here - we do have a good relationship with Waves and do have their plugins for testing.

I could not reproduce your problem. Initially - your BPM parameter values were off by a little so I adjusted them so that the “Default” variation was at 120bpm, the other ones are exactly as their name suggests except for 7 and 8 which I set to 30 and 60 respectively.

I switched, reloaded the gig etc. but could never see an issue. It always recalls the correct value.
I attached the gig file with precise values below.

TIP: Holding down the CTRL while moving a slider or a knob will allow you to adjust the value in “fine-grain mode” which sometimes helps with sensitive parameters.

This is Waves version 10.0.016 build E 142082 in case you are running an old version.

COOS FX 1.1.gig (116.3 KB)


#11

Thank you for following up on this. Have not had chance to try your updated file yet as we have been closed due to the Lunar New Year.

A couple of details that I should have highlighted earlier.

  1. I’m using Waves 9 (not sure of the exact version). Dont think I am able to upgrade with out purchasing the plugin again

  2. The error does not occur every time, usually it recalls correctly the first few times, hence my comment above the I thought the issue was resolved. However, I have noticed that rapidly switching between variations seems to trigger the error.

  3. Perhaps most importantly, the error values are always those used in a different variation. e.g. moving from “72” to “140” in my file sometimes recalls a BPM of “64”. There is no pattern to which other value is wrongly recalled, but it is always another variation value rather than a completely random number.


#12

Got it. This is most likely a plugin bug.
See if there is maybe an update to your plugins, but this does not seem like a GP issue. I tested with Waves v10, and everything worked there.


#13

There were a ton of issues with Waves 9 which were not fixed until Waves 10 was released.